[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <82520012-9940-7f2b-3bac-bea5c2396ccd@web.de>
Date: Sun, 17 Nov 2019 15:15:44 +0100
From: Markus Elfring <Markus.Elfring@....de>
To: Namjae Jeon <namjae.jeon@...sung.com>,
linux-fsdevel@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org,
Christoph Hellwig <hch@....de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Sungjong Seo <sj1557.seo@...sung.com>,
Valdis Klētnieks <valdis.kletnieks@...edu>,
linkinjeon@...il.com
Subject: Re: [PATCH 03/13] exfat: add inode operations
…
> +++ b/fs/exfat/inode.c
…
> +static int exfat_create(struct inode *dir, struct dentry *dentry, umode_t mode,
> + bool excl)
> +{
…
+out:
+ mutex_unlock(&EXFAT_SB(sb)->s_lock);
Can the label “unlock” be more appropriate?
> +static struct dentry *exfat_lookup(struct inode *dir, struct dentry *dentry,
> + unsigned int flags)
> +{
…
> +error:
> + mutex_unlock(&EXFAT_SB(sb)->s_lock);
Would you like to use the label “unlock” also at this place (and similar ones)?
> +static int exfat_search_empty_slot(struct super_block *sb,
> + struct exfat_hint_femp *hint_femp, struct exfat_chain *p_dir,
> + int num_entries)
> +{
…
> +out:
> + kfree(clu);
How do you think about to rename the label to “free_clu”?
Regards,
Markus
Powered by blists - more mailing lists