lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 21 Nov 2019 15:10:10 +0100
From:   Markus Elfring <Markus.Elfring@....de>
To:     Namjae Jeon <namjae.jeon@...sung.com>,
        linux-fsdevel@...r.kernel.org
Cc:     linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org,
        Christoph Hellwig <hch@....de>,
        Daniel Wagner <dwagner@...e.de>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Nikolay Borisov <nborisov@...e.com>,
        Sungjong Seo <sj1557.seo@...sung.com>,
        Valdis Klētnieks <valdis.kletnieks@...edu>,
        linkinjeon@...il.com
Subject: Re: [PATCH v4 06/13] exfat: add exfat entry operations

…
> +++ b/fs/exfat/fatent.c
…
> +int exfat_free_cluster(struct inode *inode, struct exfat_chain *p_chain)
> +{
…
> +out:
> +	sbi->used_clusters -= num_clusters;

Can a label like “decrement_counter” be more helpful?


…
> +int exfat_mirror_bh(struct super_block *sb, sector_t sec,
> +		struct buffer_head *bh)
> +{
…
> +		if (!c_bh) {
> +			err = -ENOMEM;
> +			goto out;
> +		}

Can it be nicer to return directly?

…
> +out:
> +	return err;
> +}

Would you like to omit such a label for this function implementation?

Regards,
Markus

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ