lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 29 Nov 2019 10:26:57 -0700
From:   Logan Gunthorpe <logang@...tatee.com>
To:     James Sewart <jamessewart@...sta.com>
Cc:     linux-pci@...r.kernel.org, Christoph Hellwig <hch@...radead.org>,
        Dmitry Safonov <0x7f454c46@...il.com>,
        iommu@...ts.linux-foundation.org, linux-kernel@...r.kernel.org,
        Dmitry Safonov <dima@...sta.com>,
        Alex Williamson <alex.williamson@...hat.com>,
        Bjorn Helgaas <helgaas@...nel.org>
Subject: Re: [PATCH v4 1/2] PCI: Add parameter nr_devfns to pci_add_dma_alias



On 2019-11-29 10:19 a.m., James Sewart wrote:
> 
> 
>> On 29 Nov 2019, at 16:50, Logan Gunthorpe <logang@...tatee.com> wrote:
>>
>>
>>
>> On 2019-11-29 5:49 a.m., James Sewart wrote:
>>> pci_add_dma_alias can now be used to create a dma alias for a range of
>>> devfns.
>>>
>>> Signed-off-by: James Sewart <jamessewart@...sta.com>
>>> ---
>>> drivers/pci/pci.c    | 23 ++++++++++++++++++-----
>>> drivers/pci/quirks.c | 14 +++++++-------
>>> include/linux/pci.h  |  2 +-
>>> 3 files changed, 26 insertions(+), 13 deletions(-)
>>>
>>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>>> index a97e2571a527..9b0e3481fe17 100644
>>> --- a/drivers/pci/pci.c
>>> +++ b/drivers/pci/pci.c
>>> @@ -5857,7 +5857,8 @@ int pci_set_vga_state(struct pci_dev *dev, bool decode,
>>> /**
>>>  * pci_add_dma_alias - Add a DMA devfn alias for a device
>>>  * @dev: the PCI device for which alias is added
>>> - * @devfn: alias slot and function
>>> + * @devfn_from: alias slot and function
>>> + * @nr_devfns: Number of subsequent devfns to alias
>>>  *
>>>  * This helper encodes an 8-bit devfn as a bit number in dma_alias_mask
>>>  * which is used to program permissible bus-devfn source addresses for DMA
>>> @@ -5873,8 +5874,14 @@ int pci_set_vga_state(struct pci_dev *dev, bool decode,
>>>  * cannot be left as a userspace activity).  DMA aliases should therefore
>>>  * be configured via quirks, such as the PCI fixup header quirk.
>>>  */
>>> -void pci_add_dma_alias(struct pci_dev *dev, u8 devfn)
>>> +void pci_add_dma_alias(struct pci_dev *dev, u8 devfn_from, unsigned nr_devfns)
>>> {
>>> +	int devfn_to;
>>> +
>>> +	if (nr_devfns > U8_MAX+1)
>>> +		nr_devfns = U8_MAX+1;
>>
>> Why +1? That doesn't seem right to me….
> 
> U8_MAX is the max number U8 can represent(255) but is one less than the number 
> of values it can represent(256). devfns can be 0.0 to 1f.7 inclusive(I think) 
> so the number of possible devfns is 256. Thinking about it, maybe the 
> zalloc should be U8_MAX+1 too?
> 
> I might be wrong though, what do you reckon?

Right, yes, but I actually think the original code is wrong. It's only
allocating a bitmap that holds 255 values and you're trying to insert
256 ones into that bitmap. It's probably ok, because there's no way to
allocate an odd sized bitmap, but it's probably worth fixing for clarity.

It also looks wrong in pci_for_each_dma_alias() as well, so I'd probably
fix both those up in a separate prep-patch.

Logan

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ