lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 3 Dec 2019 14:20:36 -0800
From:   Sean Christopherson <sean.j.christopherson@...el.com>
To:     Peter Xu <peterx@...hat.com>
Cc:     linux-kernel@...r.kernel.org, kvm@...r.kernel.org,
        Nitesh Narayan Lal <nitesh@...hat.com>,
        Paolo Bonzini <pbonzini@...hat.com>,
        Vitaly Kuznetsov <vkuznets@...hat.com>
Subject: Re: [PATCH v4 3/6] KVM: X86: Use APIC_DEST_* macros properly in
 kvm_lapic_irq.dest_mode

On Tue, Dec 03, 2019 at 05:15:19PM -0500, Peter Xu wrote:
> On Tue, Dec 03, 2019 at 02:07:52PM -0800, Sean Christopherson wrote:
> > On Tue, Dec 03, 2019 at 11:59:00AM -0500, Peter Xu wrote:
> > > diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
> > > index b79cd6aa4075..f815c97b1b57 100644
> > > --- a/arch/x86/include/asm/kvm_host.h
> > > +++ b/arch/x86/include/asm/kvm_host.h
> > > @@ -1022,6 +1022,11 @@ struct kvm_lapic_irq {
> > >  	bool msi_redir_hint;
> > >  };
> > >  
> > > +static inline u16 kvm_lapic_irq_dest_mode(bool dest_mode)
> > > +{
> > > +	return dest_mode ? APIC_DEST_LOGICAL : APIC_DEST_PHYSICAL;
> > 
> > IMO this belongs in ioapic.c as it's specifically provided for converting
> > an I/O APIC redirection entry into a local APIC destination mode.  Without
> > the I/O APIC context, %true==APIC_DEST_LOGICAL looks like a completely
> > arbitrary decision.  And if it's in ioapic.c, it can take the union
> > of a bool, which avoids the casting and shortens the callers.  E.g.:
> > 
> > static u64 ioapic_to_lapic_dest_mode(union kvm_ioapic_redirect_entry *e)
> > {
> > 	return e->fields.dest_mode ?  APIC_DEST_LOGICAL : APIC_DEST_PHYSICAL;
> > }
> > 
> > The other option would be to use the same approach as delivery_mode and
> > open code the shift.
> 
> It's also used for MSI address encodings, please see below [1].

Boooh.  How about naming the param "logical_dest_mode" or something else
with "logical" in the name so that the correctness of the function itself
is apparent?

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ