lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 4 Dec 2019 13:58:41 -0800
From:   Wei Wang <wvw@...gle.com>
To:     Amit Kucheria <amit.kucheria@...durent.com>
Cc:     Wei Wang <wei.vince.wang@...il.com>,
        Zhang Rui <rui.zhang@...el.com>,
        Eduardo Valentin <edubezval@...il.com>,
        Daniel Lezcano <daniel.lezcano@...aro.org>,
        Linux PM list <linux-pm@...r.kernel.org>,
        LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] thermal: create softlink by name for thermal_zone and cooling_device

On Wed, Dec 4, 2019 at 4:45 AM Amit Kucheria
<amit.kucheria@...durent.com> wrote:
>
> On Mon, Nov 11, 2019 at 11:22 PM Wei Wang <wvw@...gle.com> wrote:
> >
> > On Sun, Nov 10, 2019 at 9:26 PM Amit Kucheria
> > <amit.kucheria@...durent.com> wrote:
> > >
> > > On Thu, Oct 17, 2019 at 3:04 AM Wei Wang <wvw@...gle.com> wrote:
> > > >
> > > > On Wed, Oct 16, 2019 at 10:16 AM Amit Kucheria
> > > > <amit.kucheria@...durent.com> wrote:
> > > > >
> > > > > On Wed, Oct 16, 2019 at 10:20 PM Amit Kucheria
> > > > > <amit.kucheria@...durent.com> wrote:
> > > > > >
> > > > > > On Tue, Oct 15, 2019 at 11:43 AM Wei Wang <wvw@...gle.com> wrote:
> > > > > > >
> > > > > > > The paths thermal_zone%d and cooling_device%d are not intuitive and the
> > > > > > > numbers are subject to change due to device tree change. This usually
> > > > > > > leads to tree traversal in userspace code.
> > > > > > > The patch creates `tz-by-name' and `cdev-by-name' for thermal zone and
> > > > > > > cooling_device respectively.
> > > > > >
> > > > > > I like this.
> > > > > >
> > > > > > > Signed-off-by: Wei Wang <wvw@...gle.com>
> > > > > > > ---
> > > > > > >  drivers/thermal/thermal_core.c | 23 +++++++++++++++++++++--
> > > > > > >  1 file changed, 21 insertions(+), 2 deletions(-)
> > > > > > >
> > > > > > > diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
> > > > > > > index d4481cc8958f..0ff8fb1d7b0a 100644
> > > > > > > --- a/drivers/thermal/thermal_core.c
> > > > > > > +++ b/drivers/thermal/thermal_core.c
> > > > > > > @@ -22,6 +22,7 @@
> > > > > > >  #include <net/netlink.h>
> > > > > > >  #include <net/genetlink.h>
> > > > > > >  #include <linux/suspend.h>
> > > > > > > +#include <linux/kobject.h>
> > > > > > >
> > > > > > >  #define CREATE_TRACE_POINTS
> > > > > > >  #include <trace/events/thermal.h>
> > > > > > > @@ -46,6 +47,8 @@ static DEFINE_MUTEX(poweroff_lock);
> > > > > > >
> > > > > > >  static atomic_t in_suspend;
> > > > > > >  static bool power_off_triggered;
> > > > > > > +static struct kobject *cdev_link_kobj;
> > > > > > > +static struct kobject *tz_link_kobj;
> > > > > > >
> > > > > > >  static struct thermal_governor *def_governor;
> > > > > > >
> > > > > > > @@ -954,7 +957,7 @@ __thermal_cooling_device_register(struct device_node *np,
> > > > > > >         struct thermal_zone_device *pos = NULL;
> > > > > > >         int result;
> > > > > > >
> > > > > > > -       if (type && strlen(type) >= THERMAL_NAME_LENGTH)
> > > > > > > +       if (!type || !type[0] || strlen(type) >= THERMAL_NAME_LENGTH)
> > > > > > >                 return ERR_PTR(-EINVAL);
> > > > > >
> > > > > > This should be a separate fix, if needed.
> > > > Agree, but the link now requires that "" as invalid _type_.
> > >
> > > I'm not sure I understand. What does this change have to do with
> > > adding symlinks below?
> > >
> >
> > cdev->type will be used later in sysfs_create_link and adding "" as
> > symlink is kind of bad practise AIUI.
> >
>
> Perhaps I'm being dense here, in which case my apologies.
>
> But what stops us from splitting the patch into two?
> 1. Make type == "" as invalid by using your change above and fixing up
> the strlcpy(cdev->type....) further down.
> 2. Create the actual symlinks in a separate patch.
>
> Regards,
> Amit
>
Updated with v2, thanks.

>
> > > > > >
> > > > > > >         if (!ops || !ops->get_max_state || !ops->get_cur_state ||
> > > > > > > @@ -989,9 +992,15 @@ __thermal_cooling_device_register(struct device_node *np,
> > > > > > >                 return ERR_PTR(result);
> > > > > > >         }
> > > > > > >
> > > > > > > -       /* Add 'this' new cdev to the global cdev list */
> > > > > > > +       /* Add 'this' new cdev to the global cdev list and create link*/
> > > > > > >         mutex_lock(&thermal_list_lock);
> > > > > > >         list_add(&cdev->node, &thermal_cdev_list);
> > > > > > > +       if (!cdev_link_kobj)
> > > > > > > +               cdev_link_kobj = kobject_create_and_add("cdev-by-name",
> > > > > > > +                                               cdev->device.kobj.parent);
> > > > > > > +       if (!cdev_link_kobj || sysfs_create_link(cdev_link_kobj,
> > > > > > > +                                               &cdev->device.kobj, cdev->type))
> > > > > > > +               dev_err(&cdev->device, "Failed to create cdev-by-name link\n");
> > > > > >
> > > > > > Any reason not to use the following form instead? It seems easier to read.
> > > > > >
> > > > > > if (!cdev_link_kobj) {
> > > > > >                cdev_link_kobj = kobject_create_and_add("cdev-by-name",
> > > > > >                                                cdev->device.kobj.parent);
> > > > > >               ret = sysfs_create_link(cdev_link_kobj,
> > > > > >                                               &cdev->device.kobj, cdev->type))
> > > > > >               if (ret)
> > > > > >                        dev_err(&cdev->device, "Failed to create
> > > > > > cdev-by-name link\n");
> > > > > > }
> > > > >
> > > > > I can now see why you had to do that - none of the other links would
> > > > > get created after the first one.
> > > > >
> > > > > Perhaps create the directories in the __init functions and only create
> > > > > the links here?
> > > > >
> > > > AFAICT, this is no such API except the private get_device_parent()
> > > > under driver/base/. Also the lazy initialization makes sense in such
> > > > case when there is no thermal device attached. Looks like the class
> > > > dir is also lazy-initialized when first device registered
> > > > https://elixir.bootlin.com/linux/v5.3.5/source/drivers/base/core.c#L1790.
> > >
> > > OK.
> > >
> > > > >
> > > > > > >         mutex_unlock(&thermal_list_lock);
> > > > > > >
> > > > > > >         /* Update binding information for 'this' new cdev */
> > > > > > > @@ -1157,6 +1166,8 @@ void thermal_cooling_device_unregister(struct thermal_cooling_device *cdev)
> > > > > > >                         }
> > > > > > >                 }
> > > > > > >         }
> > > > > > > +       if (cdev_link_kobj)
> > > > > > > +               sysfs_remove_link(cdev_link_kobj, cdev->type);
> > > > > > >
> > > > > > >         mutex_unlock(&thermal_list_lock);
> > > > > > >
> > > > > > > @@ -1340,6 +1351,12 @@ thermal_zone_device_register(const char *type, int trips, int mask,
> > > > > > >
> > > > > > >         mutex_lock(&thermal_list_lock);
> > > > > > >         list_add_tail(&tz->node, &thermal_tz_list);
> > > > > > > +       if (!tz_link_kobj)
> > > > > > > +               tz_link_kobj = kobject_create_and_add("tz-by-name",
> > > > > > > +                                               tz->device.kobj.parent);
> > > > > > > +       if (!tz_link_kobj || sysfs_create_link(tz_link_kobj,
> > > > > > > +                                               &tz->device.kobj, tz->type))
> > > > > > > +               dev_err(&tz->device, "Failed to create tz-by-name link\n");
> > > > > >
> > > > > > Same as above.
> > > > > >
> > > > > > >         mutex_unlock(&thermal_list_lock);
> > > > > > >
> > > > > > >         /* Bind cooling devices for this zone */
> > > > > > > @@ -1411,6 +1428,8 @@ void thermal_zone_device_unregister(struct thermal_zone_device *tz)
> > > > > > >                         }
> > > > > > >                 }
> > > > > > >         }
> > > > > > > +       if (tz_link_kobj)
> > > > > > > +               sysfs_remove_link(tz_link_kobj, tz->type);
> > > > > > >
> > > > > > >         mutex_unlock(&thermal_list_lock);
> > > > > > >
> > > > > > > --
> > > > > > > 2.23.0.700.g56cf767bdb-goog
> > > > > > >

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ