[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191205144941.GA12859@qmqm.qmqm.pl>
Date: Thu, 5 Dec 2019 15:49:41 +0100
From: Michał Mirosław <mirq-linux@...e.qmqm.pl>
To: Jérôme Pouiller <Jerome.Pouiller@...abs.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"devel@...verdev.osuosl.org" <devel@...verdev.osuosl.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] staging: wfx: fix reset GPIO polarity
On Thu, Dec 05, 2019 at 02:08:23PM +0000, Jérôme Pouiller wrote:
> On Wednesday 4 December 2019 17:59:46 CET Michał Mirosław wrote:
> > Driver inverts meaning of GPIO_ACTIVE_LOW/HIGH. Fix it to prevent
> > confusion.
> >
> > Signed-off-by: Michał Mirosław <mirq-linux@...e.qmqm.pl>
> > ---
> > drivers/staging/wfx/bus_spi.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/staging/wfx/bus_spi.c b/drivers/staging/wfx/bus_spi.c
> > index ab0cda1e124f..73d0157a86ba 100644
> > --- a/drivers/staging/wfx/bus_spi.c
> > +++ b/drivers/staging/wfx/bus_spi.c
> > @@ -199,9 +199,9 @@ static int wfx_spi_probe(struct spi_device *func)
> > if (!bus->gpio_reset) {
> > dev_warn(&func->dev, "try to load firmware anyway\n");
> > } else {
> > - gpiod_set_value(bus->gpio_reset, 0);
> > - udelay(100);
> > gpiod_set_value(bus->gpio_reset, 1);
> > + udelay(100);
> > + gpiod_set_value(bus->gpio_reset, 0);
> > udelay(2000);
> > }
> Hello Michał,
>
> I did not find real consensus in kernel code. My personal taste would
> be to keep this gpio "ACTIVE_HIGH" and rename it gpio_nreset. What do
> you think about it?
>
> (in add, this solution would explicitly change the name of the DT
> attribute instead of changing the semantic of the existing attribute)
As a user (board developer) I would expect that DT describes the
GPIO meaning directly: so when I specify GPIO_ACTIVE_HIGH flag I also
wire up the board so that outputing 1 would match the active state of
the chip's signal (that might be inverted for some reason). I think we
should stick to what is said in Documentation/devicetree/bindings/gpio.txt
(section 1.1).
Since this is a new driver in kernel I would prefer to fix it at the start.
Changing the name of the GPIO would also be ok, but since there is no DT
binding yet, I guess there will come up an issue of 'compatible' string
format that does not match 'vendor,chip' now, so we can use the difference
for backwards compatibility with out-of-tree driver if needed.
Best Regards,
Michał Mirosław
Powered by blists - more mailing lists