[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20191211175822.1925-1-sean.j.christopherson@intel.com>
Date: Wed, 11 Dec 2019 09:58:20 -0800
From: Sean Christopherson <sean.j.christopherson@...el.com>
To: Paolo Bonzini <pbonzini@...hat.com>
Cc: Sean Christopherson <sean.j.christopherson@...el.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Wanpeng Li <wanpengli@...cent.com>,
Jim Mattson <jmattson@...gle.com>,
Joerg Roedel <joro@...tes.org>, kvm@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 0/2] KVM: x86: X86_FEATURE bit() cleanup
Small series to add build-time protections on reverse CPUID lookup (and
other usages of bit()), and to rename the misleading-generic bit() helper
to something that better conveys its purpose.
Sean Christopherson (2):
KVM: x86: Add build-time assertion on usage of bit()
KVM: x86: Refactor and rename bit() to feature_bit() macro
arch/x86/kvm/cpuid.c | 2 +-
arch/x86/kvm/cpuid.h | 4 ++--
arch/x86/kvm/emulate.c | 8 +++-----
arch/x86/kvm/svm.c | 4 ++--
arch/x86/kvm/vmx/vmx.c | 42 +++++++++++++++++++++---------------------
arch/x86/kvm/x86.h | 24 ++++++++++++++++++++++--
6 files changed, 51 insertions(+), 33 deletions(-)
--
2.24.0
Powered by blists - more mailing lists