[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191211145450.GV32742@smile.fi.intel.com>
Date: Wed, 11 Dec 2019 16:54:50 +0200
From: Andy Shevchenko <andriy.shevchenko@...el.com>
To: Matti Vaittinen <matti.vaittinen@...rohmeurope.com>
Cc: mazziesaccount@...il.com,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
Andy Shevchenko <andy@...nel.org>,
Linus Walleij <linus.walleij@...aro.org>,
linux-gpio@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] pinctrl: pinctrl-intel: Use GPIO direction
definitions
On Wed, Dec 11, 2019 at 04:32:24PM +0200, Matti Vaittinen wrote:
> Use new GPIO_LINE_DIRECTION_IN and GPIO_LINE_DIRECTION_OUT when
> returning GPIO direction to GPIO framework.
Thanks for the patch!
My comment below.
> - return !!(padcfg0 & PADCFG0_GPIOTXDIS);
> + return padcfg0 & PADCFG0_GPIOTXDIS ? GPIO_LINE_DIRECTION_IN :
> + GPIO_LINE_DIRECTION_OUT;
Despite I have told about ternary operator before, the most important here is
readability as well. With these definitions applied to the initial code the
readability has been slightly decreased.
Two variants to fix, though I prefer second one due to less stack use.
1/
u32 tmp;
...
tmp = padcfg0 & PADCFG0_GPIOTXDIS;
return tmp ? GPIO_LINE_DIRECTION_IN : GPIO_LINE_DIRECTION_OUT;
2/
if (padcfg0 & PADCFG0_GPIOTXDIS)
return GPIO_LINE_DIRECTION_IN;
return GPIO_LINE_DIRECTION_OUT;
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists