[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191219085106.GA8141@krava>
Date: Thu, 19 Dec 2019 09:51:06 +0100
From: Jiri Olsa <jolsa@...hat.com>
To: "fujita.yuya@...itsu.com" <fujita.yuya@...itsu.com>
Cc: 'Peter Zijlstra' <peterz@...radead.org>,
'Ingo Molnar' <mingo@...hat.com>,
'Arnaldo Carvalho de Melo' <acme@...nel.org>,
'Jiri Olsa' <jolsa@...nel.org>,
"'linux-kernel@...r.kernel.org'" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] perf tools: Fix variable name's inconsistency in
hists__for_each macro
On Thu, Dec 19, 2019 at 08:08:32AM +0000, fujita.yuya@...itsu.com wrote:
> From: Yuya Fujita <fujita.yuya@...itsu.com>
>
> Variable names are inconsistent in hists__for_each macro.
> Due to this inconsistency, the macro replaces its second argument with "fmt"
> regardless of its original name.
> So far it works because only "fmt" is passed to the second argument.
hum, I think it works because all the instances that use these macros
have 'fmt' variable passed in
> However, this behavior is not expected and should be fixed.
>
> Fixes: f0786af536bb ("perf hists: Introduce hists__for_each_format macro")
> Fixes: aa6f50af822a ("perf hists: Introduce hists__for_each_sort_list macro")
nice ;-)
Acked-by: Jiri Olsa <jolsa@...nel.org>
thanks,
jirka
> Signed-off-by: Yuya Fujita <fujita.yuya@...itsu.com>
> ---
> tools/perf/util/hist.h | 4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/tools/perf/util/hist.h b/tools/perf/util/hist.h
> index 4528690..0aa63ae 100644
> --- a/tools/perf/util/hist.h
> +++ b/tools/perf/util/hist.h
> @@ -339,10 +339,10 @@ static inline void perf_hpp__prepend_sort_field(struct perf_hpp_fmt *format)
> list_for_each_entry_safe(format, tmp, &(_list)->sorts, sort_list)
>
> #define hists__for_each_format(hists, format) \
> - perf_hpp_list__for_each_format((hists)->hpp_list, fmt)
> + perf_hpp_list__for_each_format((hists)->hpp_list, format)
>
> #define hists__for_each_sort_list(hists, format) \
> - perf_hpp_list__for_each_sort_list((hists)->hpp_list, fmt)
> + perf_hpp_list__for_each_sort_list((hists)->hpp_list, format)
>
> extern struct perf_hpp_fmt perf_hpp__format[];
>
> --
> 1.7.1
>
Powered by blists - more mailing lists