[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191220170045.725fb05c.cohuck@redhat.com>
Date: Fri, 20 Dec 2019 17:00:45 +0100
From: Cornelia Huck <cohuck@...hat.com>
To: Sean Christopherson <sean.j.christopherson@...el.com>
Cc: Marc Zyngier <maz@...nel.org>, James Hogan <jhogan@...nel.org>,
Paul Mackerras <paulus@...abs.org>,
Christian Borntraeger <borntraeger@...ibm.com>,
Janosch Frank <frankja@...ux.ibm.com>,
Paolo Bonzini <pbonzini@...hat.com>,
James Morse <james.morse@....com>,
Julien Thierry <julien.thierry.kdev@...il.com>,
Suzuki K Poulose <suzuki.poulose@....com>,
David Hildenbrand <david@...hat.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Wanpeng Li <wanpengli@...cent.com>,
Jim Mattson <jmattson@...gle.com>,
Joerg Roedel <joro@...tes.org>,
linux-arm-kernel@...ts.infradead.org, kvmarm@...ts.cs.columbia.edu,
linux-mips@...r.kernel.org, kvm-ppc@...r.kernel.org,
kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
Greg Kurz <groug@...d.org>
Subject: Re: [PATCH v2 30/45] KVM: Move vcpu alloc and init invocation to
common code
On Fri, 20 Dec 2019 07:53:30 -0800
Sean Christopherson <sean.j.christopherson@...el.com> wrote:
> On Fri, Dec 20, 2019 at 10:33:25AM +0100, Cornelia Huck wrote:
> > On Wed, 18 Dec 2019 13:55:15 -0800
> > Sean Christopherson <sean.j.christopherson@...el.com> wrote:
> > > +int kvm_arch_vcpu_create(struct kvm_vcpu *vcpu)
> > > {
> > > - struct kvm_vcpu *vcpu;
> > > struct sie_page *sie_page;
> > > int rc;
> > >
> > > - rc = -ENOMEM;
> > > -
> > > - vcpu = kmem_cache_zalloc(kvm_vcpu_cache, GFP_KERNEL);
> > > - if (!vcpu)
> > > - goto out;
> > > -
> > > - rc = kvm_vcpu_init(vcpu, kvm, id);
> > > - if (rc)
> > > - goto out_free_cpu;
> > > -
> > > - rc = -ENOMEM;
> > > -
> > > BUILD_BUG_ON(sizeof(struct sie_page) != 4096);
> > > sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL);
> > > if (!sie_page)
> > > - goto out_uninit_vcpu;
> > > + return -ENOMEM;
> > >
> > > vcpu->arch.sie_block = &sie_page->sie_block;
> > > vcpu->arch.sie_block->itdba = (unsigned long) &sie_page->itdb;
> > > @@ -3087,15 +3070,11 @@ struct kvm_vcpu *kvm_arch_vcpu_create(struct kvm *kvm,
> > > vcpu->arch.sie_block);
> > > trace_kvm_s390_create_vcpu(id, vcpu, vcpu->arch.sie_block);
> > >
> > > - return vcpu;
> > > + return 0;
> > > +
> > > out_free_sie_block:
> > > free_page((unsigned long)(vcpu->arch.sie_block));
> > > -out_uninit_vcpu:
> > > - kvm_vcpu_uninit(vcpu);
> > > -out_free_cpu:
> > > - kmem_cache_free(kvm_vcpu_cache, vcpu);
> > > -out:
> > > - return ERR_PTR(rc);
> > > + return rc;
> >
> > This is getting a bit hard to follow across the patches, but I think rc
> > is now only set for ucontrol guests. So this looks correct right now,
> > but feels a bit brittle... should we maybe init rc to 0 and always
> > return rc instead?
>
> Yes, but only for a few patches until kvm_s390_vcpu_setup() is introduced,
> at which point @rc is unconditionally set at the end.
Indeed; so feel free to leave this as-is.
Reviewed-by: Cornelia Huck <cohuck@...hat.com>
Powered by blists - more mailing lists