[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191223175005.GA31446@arm.com>
Date: Mon, 23 Dec 2019 17:50:20 +0000
From: Ionela Voinescu <ionela.voinescu@....com>
To: Thara Gopinath <thara.gopinath@...aro.org>
Cc: mingo@...hat.com, peterz@...radead.org, vincent.guittot@...aro.org,
rui.zhang@...el.com, qperret@...gle.com, daniel.lezcano@...aro.org,
viresh.kumar@...aro.org, linux-kernel@...r.kernel.org,
amit.kachhap@...il.com, javi.merino@...nel.org,
amit.kucheria@...durent.com
Subject: Re: [Patch v6 3/7] Add infrastructure to store and update
instantaneous thermal pressure
Hi Thara,
On Wednesday 11 Dec 2019 at 23:11:44 (-0500), Thara Gopinath wrote:
> Add architecture specific APIs to update and track thermal pressure on a
> per cpu basis. A per cpu variable thermal_pressure is introduced to keep
> track of instantaneous per cpu thermal pressure. Thermal pressure is the
> delta between maximum capacity and capped capacity due to a thermal event.
> capacity and capped capacity due to a thermal event.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
This line seems to be a duplicate (initially I thought I was seeing
double :) ).
> topology_get_thermal_pressure can be hooked into the scheduler specified
> arch_scale_thermal_capacity to retrieve instantaneius thermal pressure of
> a cpu.
>
> arch_set_thermal_presure can be used to update the thermal pressure by
> providing a capped maximum capacity.
>
> Considering topology_get_thermal_pressure reads thermal_pressure and
> arch_set_thermal_pressure writes into thermal_pressure, one can argue for
> some sort of locking mechanism to avoid a stale value. But considering
> topology_get_thermal_pressure_average can be called from a system critical
> path like scheduler tick function, a locking mechanism is not ideal. This
> means that it is possible the thermal_pressure value used to calculate
> average thermal pressure for a cpu can be stale for upto 1 tick period.
>
> Signed-off-by: Thara Gopinath <thara.gopinath@...aro.org>
[...]
> diff --git a/arch/arm/include/asm/topology.h b/arch/arm/include/asm/topology.h
> index 8a0fae9..90b18c3 100644
> --- a/arch/arm/include/asm/topology.h
> +++ b/arch/arm/include/asm/topology.h
> @@ -16,6 +16,9 @@
> /* Enable topology flag updates */
> #define arch_update_cpu_topology topology_update_cpu_topology
>
> +/* Replace task scheduler's defalut thermal pressure retrieve API */
s/defalut/default
> +#define arch_scale_thermal_capacity topology_get_thermal_pressure
> +
I also think this is deserving of a better name. I would drop the
'scale' part as well as it is not used as a scale factor, as
freq_scale or cpu_scale, but it's used as a reduction in capacity
(thermal capacity pressure) due to a thermal event.
It might be too much but what do you think about:
arch_thermal_capacity_pressure?
> #else
>
> static inline void init_cpu_topology(void) { }
> diff --git a/arch/arm64/include/asm/topology.h b/arch/arm64/include/asm/topology.h
> index a4d945d..ccb277b 100644
> --- a/arch/arm64/include/asm/topology.h
> +++ b/arch/arm64/include/asm/topology.h
> @@ -25,6 +25,9 @@ int pcibus_to_node(struct pci_bus *bus);
> /* Enable topology flag updates */
> #define arch_update_cpu_topology topology_update_cpu_topology
>
> +/* Replace task scheduler's defalut thermal pressure retrieve API */
s/defalut/default
Regards,
Ionela.
Powered by blists - more mailing lists