[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200106202306.GO795@breakpoint.cc>
Date: Mon, 6 Jan 2020 21:23:06 +0100
From: Florian Westphal <fw@...len.de>
To: Richard Guy Briggs <rgb@...hat.com>
Cc: Linux-Audit Mailing List <linux-audit@...hat.com>,
LKML <linux-kernel@...r.kernel.org>,
netfilter-devel@...r.kernel.org, Paul Moore <paul@...l-moore.com>,
sgrubb@...hat.com, omosnace@...hat.com, fw@...len.de,
twoerner@...hat.com, eparis@...isplace.org, ebiederm@...ssion.com,
tgraf@...radead.org
Subject: Re: [PATCH ghak25 v2 8/9] netfilter: add audit operation field
Richard Guy Briggs <rgb@...hat.com> wrote:
> diff --git a/include/linux/audit.h b/include/linux/audit.h
> index 96cabb095eed..5eab4d898c26 100644
> --- a/include/linux/audit.h
> +++ b/include/linux/audit.h
> @@ -379,7 +379,7 @@ extern int __audit_log_bprm_fcaps(struct linux_binprm *bprm,
> extern void __audit_fanotify(unsigned int response);
> extern void __audit_tk_injoffset(struct timespec64 offset);
> extern void __audit_ntp_log(const struct audit_ntp_data *ad);
> -extern void __audit_nf_cfg(const char *name, u8 af, int nentries);
> +extern void __audit_nf_cfg(const char *name, u8 af, int nentries, int op);
Consider adding an enum instead of int op.
> if (audit_enabled)
> - audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries);
> + audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries, 1);
audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries, AUDIT_XT_OP_REPLACE);
... would be a bit more readable than '1'.
The name is just an example, you can pick something else.
Powered by blists - more mailing lists