[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8c3f5263-070d-9308-0dbf-ed65efed1734@arm.com>
Date: Fri, 10 Jan 2020 12:18:15 +0000
From: Vincenzo Frascino <vincenzo.frascino@....com>
To: Thomas Gleixner <tglx@...utronix.de>,
Dmitry Safonov <dima@...sta.com>, linux-kernel@...r.kernel.org
Cc: Dmitry Safonov <0x7f454c46@...il.com>,
Andrei Vagin <avagin@...il.com>,
Adrian Reber <adrian@...as.de>,
Andrei Vagin <avagin@...nvz.org>,
Andy Lutomirski <luto@...nel.org>,
Arnd Bergmann <arnd@...db.de>,
Christian Brauner <christian.brauner@...ntu.com>,
Cyrill Gorcunov <gorcunov@...nvz.org>,
"Eric W. Biederman" <ebiederm@...ssion.com>,
"H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...hat.com>,
Jann Horn <jannh@...gle.com>, Jeff Dike <jdike@...toit.com>,
Oleg Nesterov <oleg@...hat.com>,
Pavel Emelyanov <xemul@...tuozzo.com>,
Shuah Khan <shuah@...nel.org>,
containers@...ts.linux-foundation.org, criu@...nvz.org,
linux-api@...r.kernel.org, x86@...nel.org
Subject: Re: [PATCHv8 02/34] lib/vdso: make do_hres and do_coarse as
__always_inline
On 1/10/20 12:02 PM, Thomas Gleixner wrote:
> Vincenzo Frascino <vincenzo.frascino@....com> writes:
>> On 1/10/20 11:42 AM, Thomas Gleixner wrote:
>>>>> +» » /*·goto·allows·to·avoid·extra·inlining·of·do_hres.·*/
>>>>> +» » goto·out_hres;
>>>>
>>>> What is the performance impact of "goto out_hres"?
>>>
>>> On x86 it's invisible at least in my limited testing.
>>
>> On arm64 as well based on mine as well. Shall we keep the code more readable
>> here (without goto)?
>
> The delta patch below makes it readable again and also avoids the double
> inlining. Quick testing shows no difference.
>
I tested it on arm64 and it does not show any difference as well.
I vote for it :)
> Thanks,
>
> tglx
>
> 8<---------------
> --- a/lib/vdso/gettimeofday.c
> +++ b/lib/vdso/gettimeofday.c
> @@ -98,17 +98,15 @@ static __maybe_unused int
> msk = 1U << clock;
> if (likely(msk & VDSO_HRES)) {
> vd = &vd[CS_HRES_COARSE];
> -out_hres:
> - return do_hres(vd, clock, ts);
> } else if (msk & VDSO_COARSE) {
> do_coarse(&vd[CS_HRES_COARSE], clock, ts);
> return 0;
> } else if (msk & VDSO_RAW) {
> vd = &vd[CS_RAW];
> - /* This goto avoids extra inlining of do_hres. */
> - goto out_hres;
> + } else {
> + return -1;
> }
> - return -1;
> + return do_hres(vd, clock, ts);
> }
>
> static __maybe_unused int
>
--
Regards,
Vincenzo
Powered by blists - more mailing lists