[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200117232254.2792-2-richardw.yang@linux.intel.com>
Date: Sat, 18 Jan 2020 07:22:50 +0800
From: Wei Yang <richardw.yang@...ux.intel.com>
To: akpm@...ux-foundation.org, dan.j.williams@...el.com,
aneesh.kumar@...ux.ibm.com, kirill@...temov.name,
yang.shi@...ux.alibaba.com, richardw.yang@...ux.intel.com,
thellstrom@...are.com
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org
Subject: [PATCH 1/5] mm/mremap: format the check in move_normal_pmd() same as move_huge_pmd()
No functional change, just improve the readability and prepare for
following cleanup.
Signed-off-by: Wei Yang <richardw.yang@...ux.intel.com>
---
mm/mremap.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/mm/mremap.c b/mm/mremap.c
index 122938dcec15..bcc7aa62f2d9 100644
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -200,8 +200,9 @@ static bool move_normal_pmd(struct vm_area_struct *vma, unsigned long old_addr,
struct mm_struct *mm = vma->vm_mm;
pmd_t pmd;
- if ((old_addr & ~PMD_MASK) || (new_addr & ~PMD_MASK)
- || old_end - old_addr < PMD_SIZE)
+ if ((old_addr & ~PMD_MASK) ||
+ (new_addr & ~PMD_MASK) ||
+ old_end - old_addr < PMD_SIZE)
return false;
/*
--
2.17.1
Powered by blists - more mailing lists