[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAGOxZ52xHFedU+1DUgL02xjXzG2CtXUk3MRaq=uSUZKX=7AeDw@mail.gmail.com>
Date: Sun, 19 Jan 2020 10:09:56 +0530
From: Alim Akhtar <alim.akhtar@...il.com>
To: Bean Huo <huobean@...il.com>
Cc: Alim Akhtar <alim.akhtar@...sung.com>,
Avri Altman <avri.altman@....com>, asutoshd@...eaurora.org,
"James E.J. Bottomley" <jejb@...ux.ibm.com>,
"Martin K. Petersen" <martin.petersen@...cle.com>,
Stanley Chu <stanley.chu@...iatek.com>,
"Bean Huo (beanhuo)" <beanhuo@...ron.com>,
Bart Van Assche <bvanassche@....org>,
Tomas Winkler <tomas.winkler@...el.com>,
Can Guo <cang@...eaurora.org>, linux-scsi@...r.kernel.org,
open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v3 0/8] Use UFS device indicated maximum LU number
Hi Bean
Your patches based on which tree? At least on Jame's for-next, it give
compilation errors.
(git://git.kernel.org/pub/scm/linux/kernel/git/jejb/scsi.git)
Looks like patch-2 introduces below error:
========
drivers/scsi/ufs/ufs-qcom.c: In function ‘ufs_qcom_apply_dev_quirks’:
drivers/scsi/ufs/ufs-qcom.c:955:34: error: incompatible types when
initializing type ‘struct ufs_dev_info *’ using type ‘struct
ufs_dev_info’
struct ufs_dev_info *dev_info = hba->dev_info;
^~~
drivers/scsi/ufs/ufs-qcom.c:957:14: error: ‘struct ufs_dev_info’ has
no member named ‘dev_quirks’
if (dev_info->dev_quirks & UFS_DEVICE_QUIRK_HOST_PA_SAVECONFIGTIME)
^~
scripts/Makefile.build:265: recipe for target
'drivers/scsi/ufs/ufs-qcom.o' failed
make[3]: *** [drivers/scsi/ufs/ufs-qcom.o] Error 1
=========
On Sun, Jan 19, 2020 at 5:44 AM Bean Huo <huobean@...il.com> wrote:
>
> This series of patches is to simplify UFS driver initialization flow
> and add a new parameter max_lu_supported used to specify how many LUs
> supported by the UFS device.
> This series of patches being tested on my two platforms, Qualcomm SOC
> based and Hisilicon SOC based platforms.
>
> v1-v2:
> 1. Split ufshcd_probe_hba() based on its called flow
> 2. Delete two unnecessary functions
> 3. Add a fixup patch
> v2-v3:
> 1. Combine patches 7/9 and 8/9 of v2 to patch 7/8 of v3
> 2. Change patches 1/8 and 5/8 subject
> 3. Change the name of two functions in patch 7/8
>
> Bean Huo (8):
> scsi: ufs: Fix ufshcd_probe_hba() reture value in case
> ufshcd_scsi_add_wlus() fails
> scsi: ufs: Delete struct ufs_dev_desc
> scsi: ufs: Split ufshcd_probe_hba() based on its called flow
> scsi: ufs: move ufshcd_get_max_pwr_mode() to ufs_init_params()
> scsi: ufs: Inline two functions into their callers
> scsi: ufs: Delete is_init_prefetch from struct ufs_hba
> scsi: ufs: Add max_lu_supported in struct ufs_dev_info
> scsi: ufs: Use UFS device indicated maximum LU number
>
> drivers/scsi/ufs/ufs-mediatek.c | 7 +-
> drivers/scsi/ufs/ufs-qcom.c | 6 +-
> drivers/scsi/ufs/ufs-sysfs.c | 2 +-
> drivers/scsi/ufs/ufs.h | 25 ++-
> drivers/scsi/ufs/ufs_quirks.h | 9 +-
> drivers/scsi/ufs/ufshcd.c | 276 +++++++++++++++++++-------------
> drivers/scsi/ufs/ufshcd.h | 9 +-
> 7 files changed, 196 insertions(+), 138 deletions(-)
>
> --
> 2.17.1
>
--
Regards,
Alim
Powered by blists - more mailing lists