[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200120030415.15925-1-richardw.yang@linux.intel.com>
Date: Mon, 20 Jan 2020 11:04:11 +0800
From: Wei Yang <richardw.yang@...ux.intel.com>
To: akpm@...ux-foundation.org, richardw.yang@...ux.intel.com
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
rientjes@...gle.com
Subject: [Patch v2 0/4] mm/page_alloc.c: cleanup on check page
The patch set does some cleanup related to check page.
1. Enable passing all bad reason to __dump_page()
2. Extract common part to check page
3. Remove unnecessary bad_reason assignment
Thanks suggestions from David Rientjes.
v2:
* merge two rename patches into extract patch
* enable dump several reasons for __dump_page()
Wei Yang (4):
mm: enable dump several reasons for __dump_page()
mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison
mm/page_alloc.c: pass all bad reasons to bad_page()
mm/page_alloc.c: extract commom part to check page
include/linux/mmdebug.h | 2 +-
mm/debug.c | 11 +++---
mm/page_alloc.c | 87 +++++++++++++++++++++--------------------
3 files changed, 51 insertions(+), 49 deletions(-)
--
2.17.1
Powered by blists - more mailing lists