[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <241033bf82fc7e955dd20c0084bfd4f6fc9fc75b.camel@collabora.com>
Date: Tue, 21 Jan 2020 07:45:01 -0300
From: Ezequiel Garcia <ezequiel@...labora.com>
To: Justin Swartz <justin.swartz@...ingedge.co.za>,
Jacob Chen <jacob-chen@...wrt.com>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Heiko Stuebner <heiko@...ech.de>
Cc: linux-media@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linux-rockchip@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/4] media: rockchip/rga: add rk3228-rga to
rockchip_rga_match[]
On Mon, 2020-01-20 at 19:41 +0000, Justin Swartz wrote:
> Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"
>
> Signed-off-by: Justin Swartz <justin.swartz@...ingedge.co.za>
> ---
> drivers/media/platform/rockchip/rga/rga.c | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
> index e9ff12b6b..268116cd5 100644
> --- a/drivers/media/platform/rockchip/rga/rga.c
> +++ b/drivers/media/platform/rockchip/rga/rga.c
> @@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {
>
> static const struct of_device_id rockchip_rga_match[] = {
> {
> + .compatible = "rockchip,rk3228-rga",
> + },
Unless you need to tune something in the driver
specifically for rk3228, then you don't need a
new compatible string.
As the name implies, it's just a "compatible",
so you may simply declare your rga dts node as
compatible to "rockchip,rk3288-rga".
(Of course, this means we shouldn't have added
the rk3399 compatible string.)
Regards,
Ezequiel
Powered by blists - more mailing lists