lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200129220723.GC20736@richard>
Date:   Thu, 30 Jan 2020 06:07:23 +0800
From:   Wei Yang <richardw.yang@...ux.intel.com>
To:     David Hildenbrand <david@...hat.com>
Cc:     Wei Yang <richardw.yang@...ux.intel.com>,
        akpm@...ux-foundation.org, linux-mm@...ck.org,
        linux-kernel@...r.kernel.org, mhocko@...e.com,
        yang.shi@...ux.alibaba.com, rientjes@...gle.com
Subject: Re: [Patch v2 4/4] mm/migrate.c: handle same node and add failure in
 the same way

On Wed, Jan 29, 2020 at 11:13:23AM +0100, David Hildenbrand wrote:
>On 22.01.20 02:16, Wei Yang wrote:
>> When page is not queued for migration, there are two possible cases:
>> 
>>   * page already on the target node
>>   * failed to add to migration queue
>> 
>> Current code handle them differently, this leads to a behavior
>> inconsistency.
>> 
>> Usually for each page's status, we just do store for once. While for the
>> page already on the target node, we might store the node information for
>> twice:
>> 
>>   * once when we found the page is on the target node
>>   * second when moving the pages to target node successfully after above
>>     action
>> 
>> The reason is even we don't add the page to pagelist, but store_status()
>> does store in a range which still contains the page.
>> 
>> This patch handles these two cases in the same way to reduce this
>> inconsistency and also make the code a little easier to read.
>> 
>
>I'd rephrase to
>
>"mm/migrate.c: unify "not queued for migration" handling in do_pages_move()
>
>It can currently happen that we store the status of a page twice:
>* Once we detect that it is already on the target node
>* Once we moved a bunch of pages, and a page that's already on the
>  target node is contained in the current interval.
>
>Let's simplify the code and always call do_move_pages_to_node() in
>case we did not queue a page for migration. Note that pages that are
>already on the target node are not added to the pagelist and are,
>therefore, ignored by do_move_pages_to_node() - there is no functional
>change.
>
>The status of such a page is now only stored once.
>"
>
>> Signed-off-by: Wei Yang <richardw.yang@...ux.intel.com>
>> Acked-by: Michal Hocko <mhocko@...e.com>
>> ---
>>  mm/migrate.c | 16 ++++++++--------
>>  1 file changed, 8 insertions(+), 8 deletions(-)
>> 
>> diff --git a/mm/migrate.c b/mm/migrate.c
>> index 80d2bba57265..591f2e5caed6 100644
>> --- a/mm/migrate.c
>> +++ b/mm/migrate.c
>> @@ -1654,18 +1654,18 @@ static int do_pages_move(struct mm_struct *mm, nodemask_t task_nodes,
>>  		err = add_page_for_migration(mm, addr, current_node,
>>  				&pagelist, flags & MPOL_MF_MOVE_ALL);
>>  
>> -		if (!err) {
>> -			/* The page is already on the target node */
>> -			err = store_status(status, i, current_node, 1);
>> -			if (err)
>> -				goto out_flush;
>> -			continue;
>> -		} else if (err > 0) {
>> +		if (err > 0) {
>>  			/* The page is successfully queued for migration */
>>  			continue;
>>  		}
>>  
>> -		err = store_status(status, i, err, 1);
>> +		/*
>> +		 * Two possible cases for err here:
>> +		 * == 0: page is already on the target node, then store
>> +		 *       current_node to status
>> +		 * <  0: failed to add page to list, then store err to status
>> +		 */
>
>I'd shorten that to
>
>/*
> * If the page is already on the target node (!err), store the node,
> * otherwise, store the err.
>*/
>
>> +		err = store_status(status, i, err ? : current_node, 1);
>>  		if (err)
>>  			goto out_flush;
>>  
>> 
>
>Thanks!
>
>Reviewed-by: David Hildenbrand <david@...hat.com>
>

Yep, thanks.

I would take this :-)

>-- 
>Thanks,
>
>David / dhildenb

-- 
Wei Yang
Help you, Help me

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ