[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200130141311.zm54wadpeipckoqk@wittgenstein>
Date: Thu, 30 Jan 2020 15:13:11 +0100
From: Christian Brauner <christian.brauner@...ntu.com>
To: Al Viro <viro@...IV.linux.org.uk>
Cc: linux-fsdevel@...r.kernel.org,
Linus Torvalds <torvalds@...ux-foundation.org>,
linux-kernel@...r.kernel.org, Aleksa Sarai <cyphar@...har.com>,
David Howells <dhowells@...hat.com>,
Eric Biederman <ebiederm@...ssion.com>
Subject: Re: [PATCH 01/17] do_add_mount(): lift lock_mount/unlock_mount into
callers
On Sun, Jan 19, 2020 at 03:17:13AM +0000, Al Viro wrote:
> From: Al Viro <viro@...iv.linux.org.uk>
>
> preparation to finish_automount() fix (next commit)
>
> Signed-off-by: Al Viro <viro@...iv.linux.org.uk>
Just a naming nit below.
Acked-by: Christian Brauner <christian.brauner@...ntu.com>
> ---
> fs/namespace.c | 47 ++++++++++++++++++++++++-----------------------
> 1 file changed, 24 insertions(+), 23 deletions(-)
>
> diff --git a/fs/namespace.c b/fs/namespace.c
> index 2fd0c8bcb8c1..5f0a80f17651 100644
> --- a/fs/namespace.c
> +++ b/fs/namespace.c
> @@ -2697,45 +2697,32 @@ static int do_move_mount_old(struct path *path, const char *old_name)
> /*
> * add a mount into a namespace's mount tree
> */
> -static int do_add_mount(struct mount *newmnt, struct path *path, int mnt_flags)
> +static int do_add_mount(struct mount *newmnt, struct mountpoint *mp,
> + struct path *path, int mnt_flags)
Maybe this should now be named do_add_mount_locked() so callers know
that they need to do locking themselves?
But that's bikeshedding...
Christian
Powered by blists - more mailing lists