lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 3 Feb 2020 16:27:23 +0100
From:   Enric Balletbo i Serra <enric.balletbo@...labora.com>
To:     Prashant Malani <pmalani@...omium.org>,
        linux-kernel@...r.kernel.org
Cc:     Benson Leung <bleung@...omium.org>,
        Guenter Roeck <groeck@...omium.org>,
        Lee Jones <lee.jones@...aro.org>,
        Gwendal Grignou <gwendal@...omium.org>,
        Jonathan Cameron <Jonathan.Cameron@...wei.com>,
        Evan Green <evgreen@...omium.org>
Subject: Re: [PATCH 01/17] platform/chrome: Add EC command msg wrapper

Hi Prashant,

Many thanks to work on this. Some comments below ...

On 30/1/20 21:30, Prashant Malani wrote:
> Many callers of cros_ec_cmd_xfer_status() use a similar set up of
> allocating and filling a message buffer and then copying any received
> data to a target buffer.
> 
> Create a utility function cros_ec_send_cmd_msg() that performs this
> setup so that callers can use this function instead. Subsequent patches
> will convert callers of cros_ec_cmd_xfer_status() to the new function
> instead.
> 
> Signed-off-by: Prashant Malani <pmalani@...omium.org>
> ---
>  drivers/platform/chrome/cros_ec_proto.c     | 57 +++++++++++++++++++++
>  include/linux/platform_data/cros_ec_proto.h |  5 ++
>  2 files changed, 62 insertions(+)
> 
> diff --git a/drivers/platform/chrome/cros_ec_proto.c b/drivers/platform/chrome/cros_ec_proto.c
> index da1b1c45043333..53f3bfac71d90e 100644
> --- a/drivers/platform/chrome/cros_ec_proto.c
> +++ b/drivers/platform/chrome/cros_ec_proto.c
> @@ -5,6 +5,7 @@
>  
>  #include <linux/delay.h>
>  #include <linux/device.h>
> +#include <linux/mfd/cros_ec.h>
>  #include <linux/module.h>
>  #include <linux/platform_data/cros_ec_commands.h>
>  #include <linux/platform_data/cros_ec_proto.h>
> @@ -570,6 +571,62 @@ int cros_ec_cmd_xfer_status(struct cros_ec_device *ec_dev,
>  }
>  EXPORT_SYMBOL(cros_ec_cmd_xfer_status);
>  
> +/**
> + * cros_ec_send_cmd_msg() - Utility function to send commands to ChromeOS EC.

I'm wondering if just cros_ec_cmd() shouldn't be a better name. If it's a
replacement of current user usage of cros_ec_cmd_xfer and
cros_ec_cmd_xfer_status, this will be used a lot, and have a short name and
clear will help the users of this helper.

> + * @ec: EC device struct.
> + * @version: Command version number (often 0).
> + * @command: Command ID including offset.
> + * @outdata: Data to be sent to the EC.
> + * @outsize: Size of the &outdata buffer.
> + * @indata: Data to be received from the EC.
> + * @insize: Size of the &indata buffer.
> + *
> + * This function is a wrapper around &cros_ec_cmd_xfer_status, and performs

You say that is a wrapper around cros_ec_cmd_xfer_status but then you remove
that function, and rewrite the doc here. Just explain for what is this helper
without referencing cros_ec_cmd_xfer_status and cros_ec_cmd_xfer.

> + * some of the common work involved with sending a command to the EC. This
> + * includes allocating and filling up a &struct cros_ec_command message buffer,
> + * and copying the received data to another buffer.
> + *
> + * Return: The number of bytes transferred on success or negative error code.
> + */
> +int cros_ec_send_cmd_msg(struct cros_ec_device *ec, unsigned int version,
> +			 unsigned int command, void *outdata,
> +			 unsigned int outsize, void *indata,
> +			 unsigned int insize)

Should we change the parameter types from "unsigned int" to "u32" to match both
ec hardware and the storage type in struct cros_ec_command?

> +{
> +	struct cros_ec_command *msg;
> +	int ret;
> +
> +	msg = kzalloc(sizeof(*msg) + max(outsize, insize), GFP_KERNEL);
> +	if (!msg)
> +		return -ENOMEM;
> +
> +	msg->version = version;
> +	msg->command = command;
> +	msg->outsize = outsize;
> +	msg->insize = insize;
> +
> +	if (outdata && outsize > 0)
> +		memcpy(msg->data, outdata, outsize);
> +
> +	ret = cros_ec_cmd_xfer(ec, msg);
> +	if (ret < 0) {
> +		dev_err(ec->dev, "Command xfer error (err:%d)\n", ret);
> +		goto cleanup;
> +	} else if (msg->result != EC_RES_SUCCESS) {
> +		dev_dbg(ec->dev, "Command result (err: %d)\n", msg->result);
> +		ret = -EPROTO;
> +		goto cleanup;
> +	}
> +
> +	if (insize)
> +		memcpy(indata, msg->data, insize);
> +
> +cleanup:
> +	kfree(msg);
> +	return ret;
> +}
> +EXPORT_SYMBOL(cros_ec_send_cmd_msg);
> +
>  static int get_next_event_xfer(struct cros_ec_device *ec_dev,
>  			       struct cros_ec_command *msg,
>  			       struct ec_response_get_next_event_v1 *event,
> diff --git a/include/linux/platform_data/cros_ec_proto.h b/include/linux/platform_data/cros_ec_proto.h
> index 30098a5515231d..166ce26bdd79eb 100644
> --- a/include/linux/platform_data/cros_ec_proto.h
> +++ b/include/linux/platform_data/cros_ec_proto.h
> @@ -201,6 +201,11 @@ int cros_ec_cmd_xfer(struct cros_ec_device *ec_dev,
>  int cros_ec_cmd_xfer_status(struct cros_ec_device *ec_dev,
>  			    struct cros_ec_command *msg);
>  
> +int cros_ec_send_cmd_msg(struct cros_ec_device *ec_dev, unsigned int version,
> +			 unsigned int command, void *outdata,
> +			 unsigned int outsize, void *indata,
> +			 unsigned int insize);
> +
>  int cros_ec_register(struct cros_ec_device *ec_dev);
>  
>  int cros_ec_unregister(struct cros_ec_device *ec_dev);
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ