[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <93d1c4fd-847f-fbec-7013-708f166722f8@huawei.com>
Date: Sat, 8 Feb 2020 14:12:30 +0800
From: "yukuai (C)" <yukuai3@...wei.com>
To: Ming Lei <ming.lei@...hat.com>
CC: <axboe@...nel.dk>, <chaitanya.kulkarni@....com>,
<damien.lemoal@....com>, <bvanassche@....org>,
<dhowells@...hat.com>, <asml.silence@...il.com>,
<ajay.joshi@....com>, <linux-block@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <yi.zhang@...wei.com>,
<zhangxiaoxu5@...wei.com>, <luoshijie1@...wei.com>
Subject: Re: [PATCH] block: revert pushing the final release of request_queue
to a workqueue.
On 2020/2/7 21:04, Ming Lei wrote:
> But blk_mq_debugfs_register() in your step 3 for adding loop still may
> fail, that is why I suggest to consider to move
> blk_mq_debugfs_register() into blk_unregister_queue().
I think therer might be a problem.
static void loop_remove(struct loop_device *lo)
{
del_gendisk(lo->lo_disk);
blk_cleanup_queue(lo->lo_queue);
blk_mq_free_tag_set(&lo->tag_set);
put_disk(lo->lo_disk);
kfree(lo);
}
blk_unregister_queue() is called in del_gendisk(), while
blk_cleanup_queue() remove other files or dirs. And
blk_mq_debugfs_register() should be called at last since it
will remove everything.
Thanks
Yu Kuai
Powered by blists - more mailing lists