[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1581457759.5125.18.camel@linux.ibm.com>
Date: Tue, 11 Feb 2020 16:49:19 -0500
From: Mimi Zohar <zohar@...ux.ibm.com>
To: Tianjia Zhang <tianjia.zhang@...ux.alibaba.com>,
herbert@...dor.apana.org.au, davem@...emloft.net,
dmitry.kasatkin@...il.com, jmorris@...ei.org, serge@...lyn.com,
ebiggers@...nel.org
Cc: linux-crypto@...r.kernel.org, linux-integrity@...r.kernel.org,
linux-security-module@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] crypto: rename sm3-256 to sm3 in hash_algo_name
On Mon, 2020-02-10 at 20:44 +0800, Tianjia Zhang wrote:
> The name sm3-256 is defined in hash_algo_name in hash_info, but the
> algorithm name implemented in sm3_generic.c is sm3, which will cause
> the sm3-256 algorithm to be not found in some application scenarios of
> the hash algorithm, and an ENOENT error will occur. For example,
> IMA, keys, and other subsystems that reference hash_algo_name all use
> the hash algorithm of sm3.
>
> Signed-off-by: Tianjia Zhang <tianjia.zhang@...ux.alibaba.com>
The "hash_map" needs to be updated to reflect this change.
static struct tpm2_hash tpm2_hash_map[] = {
{HASH_ALGO_SHA1, TPM_ALG_SHA1},
{HASH_ALGO_SHA256, TPM_ALG_SHA256},
{HASH_ALGO_SHA384, TPM_ALG_SHA384},
{HASH_ALGO_SHA512, TPM_ALG_SHA512},
{HASH_ALGO_SM3_256, TPM_ALG_SM3_256},
};
Mimi
> ---
> crypto/hash_info.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/crypto/hash_info.c b/crypto/hash_info.c
> index c754cb75dd1a..a49ff96bde77 100644
> --- a/crypto/hash_info.c
> +++ b/crypto/hash_info.c
> @@ -26,7 +26,7 @@ const char *const hash_algo_name[HASH_ALGO__LAST] = {
> [HASH_ALGO_TGR_128] = "tgr128",
> [HASH_ALGO_TGR_160] = "tgr160",
> [HASH_ALGO_TGR_192] = "tgr192",
> - [HASH_ALGO_SM3_256] = "sm3-256",
> + [HASH_ALGO_SM3_256] = "sm3",
> [HASH_ALGO_STREEBOG_256] = "streebog256",
> [HASH_ALGO_STREEBOG_512] = "streebog512",
> };
Powered by blists - more mailing lists