lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 13 Feb 2020 12:47:04 -0800
From:   Yury Norov <yury.norov@...il.com>
To:     Christian Borntraeger <borntraeger@...ibm.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>,
        linux-kernel@...r.kernel.org, qemu-devel <qemu-devel@...gnu.org>,
        Allison Randal <allison@...utok.net>,
        Joe Perches <joe@...ches.com>,
        Thomas Gleixner <tglx@...utronix.de>,
        William Breathitt Gray <vilhelm.gray@...il.com>
Subject: Re: [PATCH] uapi: fix userspace breakage, use __BITS_PER_LONG for
 swap

On Thu, Feb 13, 2020 at 03:21:47PM +0100, Christian Borntraeger wrote:
> QEMU has a funny new build error message when I use the upstream kernel headers:
> 
>   CC      block/file-posix.o
> In file included from /home/cborntra/REPOS/qemu/include/qemu/timer.h:4,
>                  from /home/cborntra/REPOS/qemu/include/qemu/timed-average.h:29,
>                  from /home/cborntra/REPOS/qemu/include/block/accounting.h:28,
>                  from /home/cborntra/REPOS/qemu/include/block/block_int.h:27,
>                  from /home/cborntra/REPOS/qemu/block/file-posix.c:30:
> /usr/include/linux/swab.h: In function ‘__swab’:
> /home/cborntra/REPOS/qemu/include/qemu/bitops.h:20:34: error: "sizeof" is not defined, evaluates to 0 [-Werror=undef]
>    20 | #define BITS_PER_LONG           (sizeof (unsigned long) * BITS_PER_BYTE)
>       |                                  ^~~~~~
> /home/cborntra/REPOS/qemu/include/qemu/bitops.h:20:41: error: missing binary operator before token "("
>    20 | #define BITS_PER_LONG           (sizeof (unsigned long) * BITS_PER_BYTE)
>       |                                         ^
> cc1: all warnings being treated as errors
> make: *** [/home/cborntra/REPOS/qemu/rules.mak:69: block/file-posix.o] Error 1
> rm tests/qemu-iotests/socket_scm_helper.o
> 
> This was triggered by commit d5767057c9a ("uapi: rename ext2_swab() to swab() and share globally in swab.h")
> This patch is doing
> +#include <asm/bitsperlong.h>
> but it uses BITS_PER_LONG.
> 
> The kernel file asm/bitsperlong.h provide only __BITS_PER_LONG.
> 
> Let us use the __ variant in swap.h
> Fixes: d5767057c9a ("uapi: rename ext2_swab() to swab() and share globally in swab.h")
> Cc: Yury Norov <yury.norov@...il.com>
> Cc: Allison Randal <allison@...utok.net>
> Cc: Joe Perches <joe@...ches.com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: William Breathitt Gray <vilhelm.gray@...il.com>
> Signed-off-by: Christian Borntraeger <borntraeger@...ibm.com>
> ---
>  include/uapi/linux/swab.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/include/uapi/linux/swab.h b/include/uapi/linux/swab.h
> index fa7f97da5b76..7272f85d6d6a 100644
> --- a/include/uapi/linux/swab.h
> +++ b/include/uapi/linux/swab.h
> @@ -135,9 +135,9 @@ static inline __attribute_const__ __u32 __fswahb32(__u32 val)
>  
>  static __always_inline unsigned long __swab(const unsigned long y)
>  {
> -#if BITS_PER_LONG == 64
> +#if __BITS_PER_LONG == 64
>  	return __swab64(y);
> -#else /* BITS_PER_LONG == 32 */
> +#else /* __BITS_PER_LONG == 32 */
>  	return __swab32(y);
>  #endif
>  }

There is a patch from Torsten Hilbrich fixing this:
https://lkml.org/lkml/2020/2/12/93

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ