[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200217081758.GA2814@ninjato>
Date: Mon, 17 Feb 2020 09:17:58 +0100
From: Wolfram Sang <wsa@...-dreams.de>
To: Robert Richter <rrichter@...vell.com>
Cc: Wolfram Sang <wsa+renesas@...g-engineering.com>,
linux-i2c@...r.kernel.org,
Benjamin Tissoires <benjamin.tissoires@...hat.com>,
Phil Reid <preid@...ctromag.com.au>,
Jean Delvare <jdelvare@...e.com>,
George Cherian <gcherian@...vell.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] i2c: convert SMBus alert setup function to return an
ERRPTR
> > Signed-off-by: Wolfram Sang <wsa+renesas@...g-engineering.com>
>
> > -struct i2c_client *i2c_setup_smbus_alert(struct i2c_adapter *adapter,
> > +struct i2c_client *i2c_install_smbus_alert(struct i2c_adapter *adapter,
> > struct i2c_smbus_alert_setup *setup);
>
> This function naming is a bit odd. It creates a struct i2c_client.
> Then, there is also i2c_new_client_device() and i2c_new_device(). For
> i2c_new_client_device() there are no users at all outside of
> i2c-core-base.c (except for Falcon NIC), it is only a wrapper.
i2c_new_device (and friends) returned NULL on error. I am currently
converting all i2c_new_* functions to return an ERRPTR. So,
i2c_new_client_device is the new function, i2c_new_device is deprecated.
If you check v5.6-rc1, you will find many more users. Similarily,
i2c_new_dummy is deprecated (and removed already), i2c_new_dummy_device
is the new thing.
> So how about reducing the interface to those both only to:?
>
> i2c_new_device()
> i2c_new_device_smbus()
Given the above, it would be:
i2c_new_client_device()
i2c_new_smbus_device()
Yet, I think this is too vague. Maybe
i2c_new_smbus_alert_device()
? Note that I never used SMBus Alert, so I am happy for feedback from
people actually using it.
Thanks for the comment!
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)
Powered by blists - more mailing lists