[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200217144452.GA145700@google.com>
Date: Mon, 17 Feb 2020 09:44:52 -0500
From: Joel Fernandes <joel@...lfernandes.org>
To: paulmck@...nel.org
Cc: rcu@...r.kernel.org, linux-kernel@...r.kernel.org,
kernel-team@...com, mingo@...nel.org, jiangshanlai@...il.com,
dipankar@...ibm.com, akpm@...ux-foundation.org,
mathieu.desnoyers@...icios.com, josh@...htriplett.org,
tglx@...utronix.de, peterz@...radead.org, rostedt@...dmis.org,
dhowells@...hat.com, edumazet@...gle.com, fweisbec@...il.com,
oleg@...hat.com, Jules Irenge <jbi.octave@...il.com>
Subject: Re: [PATCH tip/core/rcu 2/3] rcu: Add missing annotation for
exit_tasks_rcu_start()
On Fri, Feb 14, 2020 at 04:25:19PM -0800, paulmck@...nel.org wrote:
> From: Jules Irenge <jbi.octave@...il.com>
>
> Sparse reports a warning at exit_tasks_rcu_start(void)
>
> |warning: context imbalance in exit_tasks_rcu_start() - wrong count at exit
>
> To fix this, this commit adds an __acquires(&tasks_rcu_exit_srcu).
> Given that exit_tasks_rcu_start() does actually call __srcu_read_lock(),
> this not only fixes the warning but also improves on the readability of
> the code.
For patch 1/3 and 2/3:
Reviewed-by: Joel Fernandes (Google) <joel@...lfernandes.org>
Though IMO it would be good to squash both the patches.
thanks,
- Joel
> Signed-off-by: Jules Irenge <jbi.octave@...il.com>
> Signed-off-by: Paul E. McKenney <paulmck@...nel.org>
> ---
> kernel/rcu/update.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/rcu/update.c b/kernel/rcu/update.c
> index a27df76..a04fe54 100644
> --- a/kernel/rcu/update.c
> +++ b/kernel/rcu/update.c
> @@ -801,7 +801,7 @@ static int __init rcu_spawn_tasks_kthread(void)
> core_initcall(rcu_spawn_tasks_kthread);
>
> /* Do the srcu_read_lock() for the above synchronize_srcu(). */
> -void exit_tasks_rcu_start(void)
> +void exit_tasks_rcu_start(void) __acquires(&tasks_rcu_exit_srcu)
> {
> preempt_disable();
> current->rcu_tasks_idx = __srcu_read_lock(&tasks_rcu_exit_srcu);
> --
> 2.9.5
>
Powered by blists - more mailing lists