[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20200223105610.GA2400@madhuparna-HP-Notebook>
Date: Sun, 23 Feb 2020 16:26:10 +0530
From: Madhuparna Bhowmik <madhuparnabhowmik10@...il.com>
To: Jiri Pirko <jiri@...nulli.us>
Cc: madhuparnabhowmik10@...il.com, jiri@...lanox.com,
davem@...emloft.net, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, joel@...lfernandes.org,
frextrite@...il.com,
linux-kernel-mentees@...ts.linuxfoundation.org, paulmck@...nel.org
Subject: Re: [PATCH] net: core: devlink.c: Hold devlink->lock from the
beginning of devlink_dpipe_table_register()
On Sun, Feb 23, 2020 at 07:43:29AM +0100, Jiri Pirko wrote:
> Sat, Feb 22, 2020 at 07:52:34AM CET, madhuparnabhowmik10@...il.com wrote:
> >From: Madhuparna Bhowmik <madhuparnabhowmik10@...il.com>
> >
> >devlink_dpipe_table_find() should be called under either
> >rcu_read_lock() or devlink->lock. devlink_dpipe_table_register()
> >calls devlink_dpipe_table_find() without holding the lock
> >and acquires it later. Therefore hold the devlink->lock
> >from the beginning of devlink_dpipe_table_register().
> >
> >Suggested-by: Jiri Pirko <jiri@...lanox.com>
> >Signed-off-by: Madhuparna Bhowmik <madhuparnabhowmik10@...il.com>
> >---
> > net/core/devlink.c | 15 +++++++++++----
> > 1 file changed, 11 insertions(+), 4 deletions(-)
> >
> >diff --git a/net/core/devlink.c b/net/core/devlink.c
> >index 3e8c94155d93..ba9dd8cb98c3 100644
> >--- a/net/core/devlink.c
> >+++ b/net/core/devlink.c
> >@@ -6840,22 +6840,29 @@ int devlink_dpipe_table_register(struct devlink *devlink,
> > {
> > struct devlink_dpipe_table *table;
> >
> >- if (devlink_dpipe_table_find(&devlink->dpipe_table_list, table_name))
> >+ mutex_lock(&devlink->lock);
> >+
> >+ if (devlink_dpipe_table_find(&devlink->dpipe_table_list, table_name)) {
> >+ mutex_unlock(&devlink->lock);
> > return -EEXIST;
> >+ }
> >
> >- if (WARN_ON(!table_ops->size_get))
> >+ if (WARN_ON(!table_ops->size_get)) {
> >+ mutex_unlock(&devlink->lock);
> > return -EINVAL;
> >+ }
> >
> > table = kzalloc(sizeof(*table), GFP_KERNEL);
> >- if (!table)
> >+ if (!table) {
> >+ mutex_unlock(&devlink->lock);
>
> Please use "goto unlock" instead of unlocking on multiple places.
>
Sure, I have sent a new patch.
Thank you,
Madhuparna
>
>
> > return -ENOMEM;
> >+ }
> >
> > table->name = table_name;
> > table->table_ops = table_ops;
> > table->priv = priv;
> > table->counter_control_extern = counter_control_extern;
> >
> >- mutex_lock(&devlink->lock);
> > list_add_tail_rcu(&table->list, &devlink->dpipe_table_list);
> > mutex_unlock(&devlink->lock);
> > return 0;
> >--
> >2.17.1
> >
Powered by blists - more mailing lists