lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 3 Mar 2020 12:29:23 -0800
From:   Matthew Wilcox <willy@...radead.org>
To:     Alexey Dobriyan <adobriyan@...il.com>
Cc:     linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/5] proc: Use ppos instead of m->version

On Tue, Mar 03, 2020 at 10:55:29PM +0300, Alexey Dobriyan wrote:
> On Sat, Feb 29, 2020 at 08:59:08AM -0800, Matthew Wilcox wrote:
> > -static void *m_next(struct seq_file *m, void *v, loff_t *pos)
> > +static void *m_next(struct seq_file *m, void *v, loff_t *ppos)
> 
> This looks like hungarian notation.

It's the standard naming convention used throughout the VFS.  loff_t is
pos, loff_t * is ppos.

$ git grep 'loff_t \*' fs/*.c |wc
     77     556    5233
$ git grep 'loff_t \*ppos' fs/*.c |wc
     43     309    2974
$ git grep 'loff_t \*pos' fs/*.c |wc
     22     168    1524

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ