[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <5d0a9d49-cbc8-08bb-8c34-065427a16bec@roeck-us.net>
Date: Fri, 6 Mar 2020 07:20:29 -0800
From: Guenter Roeck <linux@...ck-us.net>
To: Sergey.Semin@...kalelectronics.ru,
Wim Van Sebroeck <wim@...ux-watchdog.org>
Cc: Serge Semin <fancer.lancer@...il.com>,
Alexey Malahov <Alexey.Malahov@...kalelectronics.ru>,
Thomas Bogendoerfer <tsbogend@...ha.franken.de>,
Paul Burton <paulburton@...nel.org>,
Ralf Baechle <ralf@...ux-mips.org>,
linux-watchdog@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 3/7] watchdog: watchdog_dev: Use generic msec-per-sec
macro
On 3/6/20 5:27 AM, Sergey.Semin@...kalelectronics.ru wrote:
> From: Serge Semin <Sergey.Semin@...kalelectronics.ru>
>
> For better readability replace the numeric literals with globally
> available xSEC_PER_SEC macro.
>
This is really completely unrelated to the rest of the series,
and I don't really see the point. I am fine with such changes if there
are some context changes around it, but otherwise they add no value
other than being a potential source of backport conflicts.
Guenter
> Signed-off-by: Serge Semin <Sergey.Semin@...kalelectronics.ru>
> Signed-off-by: Alexey Malahov <Alexey.Malahov@...kalelectronics.ru>
> Cc: Thomas Bogendoerfer <tsbogend@...ha.franken.de>
> Cc: Paul Burton <paulburton@...nel.org>
> Cc: Ralf Baechle <ralf@...ux-mips.org>
> ---
> drivers/watchdog/watchdog_dev.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/watchdog/watchdog_dev.c b/drivers/watchdog/watchdog_dev.c
> index 8b5c742f24e8..a1a3bbe21653 100644
> --- a/drivers/watchdog/watchdog_dev.c
> +++ b/drivers/watchdog/watchdog_dev.c
> @@ -99,7 +99,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd)
> {
> /* All variables in milli-seconds */
> unsigned int hm = wdd->max_hw_heartbeat_ms;
> - unsigned int t = wdd->timeout * 1000;
> + unsigned int t = wdd->timeout * MSEC_PER_SEC;
>
> /*
> * A worker to generate heartbeat requests is needed if all of the
> @@ -121,7 +121,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd)
> static ktime_t watchdog_next_keepalive(struct watchdog_device *wdd)
> {
> struct watchdog_core_data *wd_data = wdd->wd_data;
> - unsigned int timeout_ms = wdd->timeout * 1000;
> + unsigned int timeout_ms = wdd->timeout * MSEC_PER_SEC;
> ktime_t keepalive_interval;
> ktime_t last_heartbeat, latest_heartbeat;
> ktime_t virt_timeout;
>
Powered by blists - more mailing lists