[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAD=FV=X649r8qrNRZSezUBEuJbt0oZg6VBweAGjEhxOPp0zf2w@mail.gmail.com>
Date: Wed, 11 Mar 2020 08:03:27 -0700
From: Doug Anderson <dianders@...omium.org>
To: Maulik Shah <mkshah@...eaurora.org>
Cc: Andy Gross <agross@...nel.org>,
Bjorn Andersson <bjorn.andersson@...aro.org>,
Rajendra Nayak <rnayak@...eaurora.org>,
Matthias Kaehlcke <mka@...omium.org>,
Evan Green <evgreen@...omium.org>,
Stephen Boyd <swboyd@...omium.org>,
Lina Iyer <ilina@...eaurora.org>,
linux-arm-msm <linux-arm-msm@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [RFT PATCH 1/9] drivers: qcom: rpmh-rsc: Clean code
reading/writing regs/cmds
Hi,
On Wed, Mar 11, 2020 at 1:47 AM Maulik Shah <mkshah@...eaurora.org> wrote:
>
> Hi,
>
> On 3/7/2020 5:29 AM, Douglas Anderson wrote:
> > This patch makes two changes, both of which should be no-ops:
> >
> > 1. Make read_tcs_reg() / read_tcs_cmd() symmetric to write_tcs_reg() /
> > write_tcs_cmd().
>
> i agree that there are two different write function doing same thing except last addition (RSC_DRV_CMD_OFFSET * cmd_id)
>
> can you please rename write_tcs_cmd() to write_tcs_reg(), add above operation in it, and then remove existing write_tcs_reg().
> this way we have only one read and one write function.
>
> so at the end we will two function as,
>
> static u32 read_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id)
> {
> return readl_relaxed(drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id +
> RSC_DRV_CMD_OFFSET * cmd_id);
> }
>
> static void write_tcs_reg(struct rsc_drv *drv, int reg, int tcs_id, int cmd_id,
> u32 data)
> {
> writel_relaxed(data, drv->tcs_base + reg + RSC_DRV_TCS_OFFSET * tcs_id +
> RSC_DRV_CMD_OFFSET * cmd_id);
> }
I can if you insist and this is still better than the existing
(inconsistent) code.
...but I still feel that having two functions adds value here.
Anyone else who is CCed want to weigh in and tie break?
> > 2. Change the order of operations in the above functions to make it
> > more obvious to me what the math is doing. Specifically first you
> > want to find the right TCS, then the right register, and then
> > multiply by the command ID if necessary.
> With above change, i don't think you need to re-order this.
> specifically from tcs->base, we find right "reg" first and if it happens to be tcs then intended tcs, and then cmd inside tcs.
There was never any "need" to re-order. That math works out to be the
same. This is just clearer.
As an example, let's look at this:
struct point {
int x;
int y;
};
struct point points[10];
Let's say you have:
void *points_base = &(points[0]);
...and now you want to find &(points[5].y). What does your math look like?
a) points_base + (sizeof(struct point) * 5) + 4 ;
...or...
b) points_base + 4 + (sizeof(struct point) * 5);
Both calculations give the same result, but I am arguring that "a)" is
more intuitive. Specifically you deal with the array access first and
then deal with the offset within the structure that you found.
-Doug
Powered by blists - more mailing lists