[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAJRQjodgLgZShiA4twc6FyNspyoL5h7kGtfeOC9UA=4nD_8Qxg@mail.gmail.com>
Date: Sat, 14 Mar 2020 07:18:47 +0800
From: Qiujun Huang <hqjagain@...il.com>
To: Matthew Wilcox <willy@...radead.org>
Cc: gregkh@...uxfoundation.org, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] radix-tree: fix kernel-doc for radix_tree_find_next_bit
I thought it's better to update the function description as it could
be more readable from source code.
On Sat, Mar 14, 2020 at 3:14 AM Matthew Wilcox <willy@...radead.org> wrote:
>
> On Sat, Mar 14, 2020 at 02:49:08AM +0800, Qiujun Huang wrote:
> > * radix_tree_find_next_bit - find the next set bit in a memory region
> > *
> > * @addr: The address to base the search on
> > - * @size: The bitmap size in bits
> > + * @tag: The tag index (< RADIX_TREE_MAX_TAGS)
> > * @offset: The bitnumber to start searching at
> > *
> > * Unrollable variant of find_next_bit() for constant size arrays.
> > - * Tail bits starting from size to roundup(size, BITS_PER_LONG) must be zero.
> > - * Returns next bit offset, or size if nothing found.
> > + * Returns next bit offset, or RADIX_TREE_MAP_SIZE if nothing found.
> > */
> > static __always_inline unsigned long
> > radix_tree_find_next_bit(struct radix_tree_node *node, unsigned int tag,
>
> Ugh, this is a static function with kernel-doc. What a waste of time ;-(
Powered by blists - more mailing lists