[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e2dc038b-0283-0bf6-45f6-ad2dd0775e81@redhat.com>
Date: Fri, 13 Mar 2020 09:29:47 -0400
From: Waiman Long <longman@...hat.com>
To: Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>
Cc: David Howells <dhowells@...hat.com>,
James Morris <jmorris@...ei.org>,
"Serge E. Hallyn" <serge@...lyn.com>,
Mimi Zohar <zohar@...ux.ibm.com>, keyrings@...r.kernel.org,
linux-kernel@...r.kernel.org,
linux-security-module@...r.kernel.org,
linux-integrity@...r.kernel.org,
Sumit Garg <sumit.garg@...aro.org>,
Jerry Snitselaar <jsnitsel@...hat.com>,
Roberto Sassu <roberto.sassu@...wei.com>,
Eric Biggers <ebiggers@...gle.com>,
Chris von Recklinghausen <crecklin@...hat.com>
Subject: Re: [PATCH v2 1/2] KEYS: Don't write out to userspace while holding
key semaphore
On 3/12/20 9:04 PM, Jarkko Sakkinen wrote:
> On Sun, Mar 08, 2020 at 01:04:09PM -0400, Waiman Long wrote:
>> + /*
>> + * Read methods will just return the required length
>> + * without any copying if the provided length isn't big
>> + * enough.
>> + */
>> + if ((ret > 0) && (ret <= buflen) && buffer &&
>> + copy_to_user(buffer, tmpbuf, ret))
>> + ret = -EFAULT;
> Please, reorg and remove redundant parentheses:
>
> /*
> * Read methods will just return the required length
> * without any copying if the provided length isn't big
> * enough.
> */
> if (ret > 0 && ret <= buflen) {
> if (buffer && copy_to_user(buffer, tmpbuf, ret))
> ret = -EFAULT;
> }
>
> Now the comment is attached to the exact right thing. The previous
> organization is a pain to look at when backtracking commits for
> whatever reason in the future.
Yes, I can reorganize the code.
> I'm also wondering, would it be possible to rework the code in a way
> that you don't have check whether buffer is valid on a constant basis?
One way to do that is to extract the down_read/up_read block into a
helper function and then have 2 separate paths - one for length
retrieval and another one for reading the key. I think that will make
the code a bit easier easier to read.
Thanks,
Longman
Powered by blists - more mailing lists