[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAPDyKFoKzBPNFkG=4OenZ_7ZVgqfhhEDRxsSbu6cJOSgCPPL1Q@mail.gmail.com>
Date: Mon, 16 Mar 2020 12:47:20 +0100
From: Ulf Hansson <ulf.hansson@...aro.org>
To: Baolin Wang <baolin.wang7@...il.com>
Cc: Adrian Hunter <adrian.hunter@...el.com>,
Orson Zhai <orsonzhai@...il.com>,
Chunyan Zhang <zhang.lyra@...il.com>,
Arnd Bergmann <arnd@...db.de>,
"linux-mmc@...r.kernel.org" <linux-mmc@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [RESEND PATCH 2/3] mmc: host: sdhci-sprd: Implement the
request_atomic() API
On Wed, 4 Mar 2020 at 08:42, Baolin Wang <baolin.wang7@...il.com> wrote:
>
> Implement the request_atomic() API for nonremovable cards, that means
> we can submit next request in the irq hard handler context to reduce
> latency.
>
> Signed-off-by: Baolin Wang <baolin.wang7@...il.com>
> ---
> drivers/mmc/host/sdhci-sprd.c | 28 ++++++++++++++++++++++++++--
> 1 file changed, 26 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/mmc/host/sdhci-sprd.c b/drivers/mmc/host/sdhci-sprd.c
> index 2ab42c5..bddf0f3 100644
> --- a/drivers/mmc/host/sdhci-sprd.c
> +++ b/drivers/mmc/host/sdhci-sprd.c
> @@ -426,6 +426,27 @@ static void sdhci_sprd_request(struct mmc_host *mmc, struct mmc_request *mrq)
> sdhci_request(mmc, mrq);
> }
>
> +static void sdhci_sprd_request_atomic(struct mmc_host *mmc,
> + struct mmc_request *mrq)
> +{
> + struct sdhci_host *host = mmc_priv(mmc);
> + struct sdhci_sprd_host *sprd_host = TO_SPRD_HOST(host);
> +
> + host->flags |= sprd_host->flags & SDHCI_AUTO_CMD23;
> +
> + /*
> + * From version 4.10 onward, ARGUMENT2 register is also as 32-bit
> + * block count register which doesn't support stuff bits of
> + * CMD23 argument on Spreadtrum's sd host controller.
> + */
> + if (host->version >= SDHCI_SPEC_410 &&
> + mrq->sbc && (mrq->sbc->arg & SDHCI_SPRD_ARG2_STUFF) &&
> + (host->flags & SDHCI_AUTO_CMD23))
> + host->flags &= ~SDHCI_AUTO_CMD23;
Looks like the above code is a copy of what is done in
sdhci_sprd_request(). Perhaps add a helper function that deals with
this to avoid open coding?
> +
> + sdhci_request_atomic(mmc, mrq);
> +}
> +
> static int sdhci_sprd_voltage_switch(struct mmc_host *mmc, struct mmc_ios *ios)
> {
> struct sdhci_host *host = mmc_priv(mmc);
> @@ -561,6 +582,11 @@ static int sdhci_sprd_probe(struct platform_device *pdev)
> if (ret)
> goto pltfm_free;
>
> + if (!mmc_card_is_removable(host->mmc))
> + host->mmc_host_ops.request_atomic = sdhci_sprd_request_atomic;
> + else
> + host->always_defer_done = true;
> +
> sprd_host = TO_SPRD_HOST(host);
> sdhci_sprd_phy_param_parse(sprd_host, pdev->dev.of_node);
>
> @@ -654,8 +680,6 @@ static int sdhci_sprd_probe(struct platform_device *pdev)
> if (ret)
> goto err_cleanup_host;
>
> - host->always_defer_done = true;
> -
> ret = __sdhci_add_host(host);
> if (ret)
> goto err_cleanup_host;
> --
> 1.9.1
>
Kind regards
Uffe
Powered by blists - more mailing lists