lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 18 Mar 2020 12:57:36 +0100
From:   Greg KH <gregkh@...uxfoundation.org>
To:     Chanwoo Choi <cw00.choi@...sung.com>
Cc:     chanwoo@...nel.org, myungjoo.ham@...sung.com,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] extcon: Remove unneeded extern keyword from
 extcon-provider.h

On Mon, Feb 17, 2020 at 08:05:40PM +0900, Chanwoo Choi wrote:
> On 2/17/20 7:45 PM, Greg KH wrote:
> > On Mon, Feb 17, 2020 at 07:47:28PM +0900, Chanwoo Choi wrote:
> >> The commit tb7365587f513 ("extcon: Remove unneeded extern keyword
> >> from extcon.h") removes the unneeded extern keyword from extcon header
> >> file. But, The commit tb7365587f513 has missed that deletes 'extern'
> >> keyword from extcon-provider.h. So that it deletes extern keyword
> >> from extcon-provider.h.
> >>
> >> Signed-off-by: Chanwoo Choi <cw00.choi@...sung.com>
> >> ---
> >> Dear Greg,
> >>
> >> When I removed the unneeded extern keyword from extcon hearder file for
> >> v5.6-rc1, although I should remove 'extern' keyword on both extcon.h
> >> and extcon-provider.h, I only removed them from extcon.h. It was my mistake.
> >>
> >> So that I send this patch for v5.6-rc3 release.
> >> Could you review and apply it to char-misc git repository directly?
> > 
> > Sure, but it's not really a bugfix, I'll queue it up for 5.7-rc1, ok?
> 
> Right. It is not bugfix. Just This patch is related to patch[1]
> which was merged to v5.6-rc1.
> [1] commit tb7365587f513 ("extcon: Remove unneeded extern keyword
> from extcon.h")
> 
> If you think that it is not needed to be merged for v5.6-rc3,
> I think that it is better to apply it to extcon-next branch
> for v5.7-rc1.

I'll queue this up for 5.7-rc1, thanks.

greg k-h

Powered by blists - more mailing lists