[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <877dzf4a8v.fsf@nanos.tec.linutronix.de>
Date: Fri, 20 Mar 2020 11:00:00 +0100
From: Thomas Gleixner <tglx@...utronix.de>
To: Andy Lutomirski <luto@...nel.org>,
Kyung Min Park <kyung.min.park@...el.com>
Cc: X86 ML <x86@...nel.org>, LKML <linux-kernel@...r.kernel.org>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>,
Greg KH <gregkh@...uxfoundation.org>,
Andi Kleen <ak@...ux.intel.com>,
Tony Luck <tony.luck@...el.com>,
"Raj\, Ashok" <ashok.raj@...el.com>,
"Ravi V. Shankar" <ravi.v.shankar@...el.com>,
Fenghua Yu <fenghua.yu@...el.com>
Subject: Re: [PATCH v2 2/2] x86/delay: Introduce TPAUSE delay
Andy Lutomirski <luto@...nel.org> writes:
> On Thu, Mar 19, 2020 at 9:13 PM Kyung Min Park <kyung.min.park@...el.com> wrote:
>> void use_tsc_delay(void)
>> {
>> - if (delay_fn == delay_loop)
>> + if (static_cpu_has(X86_FEATURE_WAITPKG)) {
>> + delay_halt_fn = delay_halt_tpause;
>> + delay_fn = delay_halt;
>> + } else if (delay_fn == delay_loop) {
>> delay_fn = delay_tsc;
>> + }
>> }
>
> This is an odd way to dispatch: you're using static_cpu_has(), but
> you're using it once to populate a function pointer. Why not just put
> the static_cpu_has() directly into delay_halt() and open-code the
> three variants?
Two: mwaitx and tpause.
> That will also make it a lot easier to understand the oddity with
> start and cycles.
Indeed. That makes sense. Should have thought about it :)
Thanks,
tglx
Powered by blists - more mailing lists