[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8c1916c8a0f769f390a53aeba1ffd6043e12611a.camel@perches.com>
Date: Tue, 24 Mar 2020 09:45:15 -0700
From: Joe Perches <joe@...ches.com>
To: Alain Michaud <alainmichaud@...gle.com>
Cc: Marcel Holtmann <marcel@...tmann.org>,
Miao-chen Chou <mcchou@...omium.org>,
Bluetooth Kernel Mailing List
<linux-bluetooth@...r.kernel.org>,
Luiz Augusto von Dentz <luiz.von.dentz@...el.com>,
Alain Michaud <alainm@...omium.org>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Johan Hedberg <johan.hedberg@...il.com>,
LKML <linux-kernel@...r.kernel.org>,
netdev <netdev@...r.kernel.org>
Subject: Re: [PATCH v1 1/2] Bluetooth: btusb: Indicate Microsoft vendor
extension for Intel 9460/9560 and 9160/9260
On Tue, 2020-03-24 at 11:24 -0400, Alain Michaud wrote:
> On Tue, Mar 24, 2020 at 11:19 AM Joe Perches <joe@...ches.com> wrote:
> > On Tue, 2020-03-24 at 11:10 -0400, Alain Michaud wrote:
> > > On Mon, Mar 23, 2020 at 4:11 PM Joe Perches <joe@...ches.com> wrote:
> > > > On Mon, 2020-03-23 at 19:48 +0100, Marcel Holtmann wrote:
> > > > > Hi Joe,
> > > >
> > > > Hello Marcel.
> > > >
> > > > > > > > This adds a bit mask of driver_info for Microsoft vendor extension and
> > > > > > > > indicates the support for Intel 9460/9560 and 9160/9260. See
> > > > > > > > https://docs.microsoft.com/en-us/windows-hardware/drivers/bluetooth/
> > > > > > > > microsoft-defined-bluetooth-hci-commands-and-events for more information
> > > > > > > > about the extension. This was verified with Intel ThunderPeak BT controller
> > > > > > > > where msft_vnd_ext_opcode is 0xFC1E.
> > > > > > []
> > > > > > > > diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h
> > > > > > []
> > > > > > > > @@ -315,6 +315,10 @@ struct hci_dev {
> > > > > > > > __u8 ssp_debug_mode;
> > > > > > > > __u8 hw_error_code;
> > > > > > > > __u32 clock;
> > > > > > > > + __u16 msft_vnd_ext_opcode;
> > > > > > > > + __u64 msft_vnd_ext_features;
> > > > > > > > + __u8 msft_vnd_ext_evt_prefix_len;
> > > > > > > > + void *msft_vnd_ext_evt_prefix;
> > > > > >
> > > > > > msft is just another vendor.
> > > > > >
> > > > > > If there are to be vendor extensions, this should
> > > > > > likely use a blank line above and below and not
> > > > > > be prefixed with msft_
> > > > >
> > > > > there are other vendors, but all of them are different. So this needs to be prefixed with msft_ actually. But I agree that having empty lines above and below makes it more readable.
> > > >
> > > > So struct hci_dev should become a clutter
> > > > of random vendor extensions?
> > > >
> > > > Perhaps there should instead be something like
> > > > an array of char at the end of the struct and
> > > > various vendor specific extensions could be
> > > > overlaid on that array or just add a void *
> > > > to whatever info that vendors require.
> > > I don't particularly like trailing buffers, but I agree we could
> > > possibly organize this a little better by with a struct. something
> > > like:
> > >
> > > struct msft_vnd_ext {
> > > bool f supported; // <-- Clearly calls out if the
> > > extension is supported.
> > > __u16 msft_vnd_ext_opcode; // <-- Note that this also
> > > needs to be provided by the driver. I don't recommend we have this
> > > read from the hardware since we just cause an extra redirection that
> > > isn't necessary. Ideally, this should come from the usb_table const.
> > > __u64 msft_vnd_ext_features;
> > > __u8 msft_vnd_ext_evt_prefix_len;
> > > void *msft_vnd_ext_evt_prefix;
> > > };
> > >
> > > And then simply add the struct msft_vnd_ext (and any others) to hci_dev.
> >
> > Or use an anonymous union
> That would also work, but would need to be an array of unions, perhaps
> following your original idea to have them be in a trailing array of
> unions since a controller may support more than one extension. This
> might be going overboard :)
True.
Especially true if the controller supports multiple
concurrent extensions.
Powered by blists - more mailing lists