[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1585128143.18052.3.camel@mtksdaap41>
Date: Wed, 25 Mar 2020 17:22:23 +0800
From: Yingjoe Chen <yingjoe.chen@...iatek.com>
To: Hanks Chen <hanks.chen@...iatek.com>
CC: Linus Walleij <linus.walleij@...aro.org>,
Rob Herring <robh+dt@...nel.org>,
Mark Rutland <mark.rutland@....com>,
"Matthias Brugger" <matthias.bgg@...il.com>,
Sean Wang <sean.wang@...nel.org>, <devicetree@...r.kernel.org>,
<wsd_upstream@...iatek.com>, Andy Teng <andy.teng@...iatek.com>,
<linux-kernel@...r.kernel.org>,
<linux-mediatek@...ts.infradead.org>,
Mars Cheng <mars.cheng@...iatek.com>
Subject: Re: [PATCH v4 3/6] pinctrl: mediatek: avoid virtual gpio trying to
set reg
On Wed, 2020-03-25 at 16:12 +0800, Hanks Chen wrote:
> for virtual gpios, they should not do reg setting and
> should behave as expected for eint function.
>
> Change-Id: I913501f21c841c2cb981530cd387395648f83984
Please remove Change-Id:
> Signed-off-by: Hanks Chen <hanks.chen@...iatek.com>
> Signed-off-by: Mars Cheng <mars.cheng@...iatek.com>
> ---
> drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c | 28 ++++++++++++++++++++++
> drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.h | 1 +
> drivers/pinctrl/mediatek/pinctrl-paris.c | 7 ++++++
> 3 files changed, 36 insertions(+)
>
> diff --git a/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c b/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c
> index 20e1c89..087d233 100644
> --- a/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c
> +++ b/drivers/pinctrl/mediatek/pinctrl-mtk-common-v2.c
> @@ -226,6 +226,31 @@ static int mtk_xt_find_eint_num(struct mtk_pinctrl *hw, unsigned long eint_n)
> return EINT_NA;
> }
>
> +/*
> + * Virtual GPIO only used inside SOC and not being exported to outside SOC.
> + * Some modules use virtual GPIO as eint (e.g. pmif or usb).
> + * In MTK platform, external interrupt (EINT) and GPIO is 1-1 mapping
> + * and we can set GPIO as eint.
> + * But some modules use specific eint which doesn't have real GPIO pin.
> + * So we use virtual GPIO to map it.
> + */
> +
> +bool mtk_is_virt_gpio(struct mtk_pinctrl *hw, unsigned int gpio_n)
> +{
> + const struct mtk_pin_desc *desc;
> + bool virt_gpio = false;
> +
> + if (gpio_n >= hw->soc->npins)
> + return virt_gpio;
> +
> + desc = (const struct mtk_pin_desc *)&hw->soc->pins[gpio_n];
> +
> + if (desc->funcs && !desc->funcs[desc->eint.eint_m].name)
> + virt_gpio = true;
I think removing virt_gpio and just return true/false for this function
will make it easier to read.
Joe.C
> +
> + return virt_gpio;
> +}
Powered by blists - more mailing lists