lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200331094108.GF30449@dhcp22.suse.cz>
Date:   Tue, 31 Mar 2020 11:41:08 +0200
From:   Michal Hocko <mhocko@...nel.org>
To:     "Huang, Ying" <ying.huang@...el.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>, linux-mm@...ck.org,
        linux-kernel@...r.kernel.org, Minchan Kim <minchan@...nel.org>,
        Hugh Dickins <hughd@...gle.com>,
        Rik van Riel <riel@...riel.com>
Subject: Re: [PATCH] mm, trivial: Simplify swap related code in
 try_to_unmap_one()

On Tue 31-03-20 16:46:13, Huang, Ying wrote:
> From: Huang Ying <ying.huang@...el.com>
> 
> Because PageSwapCache() will always return false if PageSwapBacked() returns
> false, and PageSwapBacked() will be check for MADV_FREE pages in
> try_to_unmap_one().  The swap related code in try_to_unmap_one() can be
> simplified to improve the readability.

My understanding is that this is a sanity check to let us know if
something breaks. Do we really want to get rid of it? Maybe it is not
really useful but if that is the case then the changelog should reflect
this fact.

> Signed-off-by: "Huang, Ying" <ying.huang@...el.com>
> Cc: Michal Hocko <mhocko@...nel.org>
> Cc: Minchan Kim <minchan@...nel.org>
> Cc: Hugh Dickins <hughd@...gle.com>
> Cc: Rik van Riel <riel@...riel.com>
> ---
>  mm/rmap.c | 27 ++++++++++++++-------------
>  1 file changed, 14 insertions(+), 13 deletions(-)
> 
> diff --git a/mm/rmap.c b/mm/rmap.c
> index 2126fd4a254b..cd3c406aeac7 100644
> --- a/mm/rmap.c
> +++ b/mm/rmap.c
> @@ -1613,19 +1613,6 @@ static bool try_to_unmap_one(struct page *page, struct vm_area_struct *vma,
>  		} else if (PageAnon(page)) {
>  			swp_entry_t entry = { .val = page_private(subpage) };
>  			pte_t swp_pte;
> -			/*
> -			 * Store the swap location in the pte.
> -			 * See handle_pte_fault() ...
> -			 */
> -			if (unlikely(PageSwapBacked(page) != PageSwapCache(page))) {
> -				WARN_ON_ONCE(1);
> -				ret = false;
> -				/* We have to invalidate as we cleared the pte */
> -				mmu_notifier_invalidate_range(mm, address,
> -							address + PAGE_SIZE);
> -				page_vma_mapped_walk_done(&pvmw);
> -				break;
> -			}
>  
>  			/* MADV_FREE page check */
>  			if (!PageSwapBacked(page)) {
> @@ -1648,6 +1635,20 @@ static bool try_to_unmap_one(struct page *page, struct vm_area_struct *vma,
>  				break;
>  			}
>  
> +			/*
> +			 * Store the swap location in the pte.
> +			 * See handle_pte_fault() ...
> +			 */
> +			if (unlikely(!PageSwapCache(page))) {
> +				WARN_ON_ONCE(1);
> +				ret = false;
> +				/* We have to invalidate as we cleared the pte */
> +				mmu_notifier_invalidate_range(mm, address,
> +							address + PAGE_SIZE);
> +				page_vma_mapped_walk_done(&pvmw);
> +				break;
> +			}
> +
>  			if (swap_duplicate(entry) < 0) {
>  				set_pte_at(mm, address, pvmw.pte, pteval);
>  				ret = false;
> -- 
> 2.25.0

-- 
Michal Hocko
SUSE Labs

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ