[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <f3e9f127-47b1-9f30-2148-3c95a5933a92@linaro.org>
Date: Fri, 3 Apr 2020 19:44:17 +0200
From: Daniel Lezcano <daniel.lezcano@...aro.org>
To: Lukasz Luba <lukasz.luba@....com>, linux-kernel@...r.kernel.org,
linux-pm@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
dri-devel@...ts.freedesktop.org, linux-omap@...r.kernel.org,
linux-mediatek@...ts.infradead.org, linux-arm-msm@...r.kernel.org,
linux-imx@....com
Cc: Morten.Rasmussen@....com, Dietmar.Eggemann@....com,
javi.merino@....com, cw00.choi@...sung.com,
b.zolnierkie@...sung.com, rjw@...ysocki.net, sudeep.holla@....com,
viresh.kumar@...aro.org, nm@...com, sboyd@...nel.org,
rui.zhang@...el.com, amit.kucheria@...durent.com, mingo@...hat.com,
peterz@...radead.org, juri.lelli@...hat.com,
vincent.guittot@...aro.org, rostedt@...dmis.org,
qperret@...gle.com, bsegall@...gle.com, mgorman@...e.de,
shawnguo@...nel.org, s.hauer@...gutronix.de, festevam@...il.com,
kernel@...gutronix.de, khilman@...nel.org, agross@...nel.org,
bjorn.andersson@...aro.org, robh@...nel.org,
matthias.bgg@...il.com, steven.price@....com,
tomeu.vizoso@...labora.com, alyssa.rosenzweig@...labora.com,
airlied@...ux.ie, daniel@...ll.ch, liviu.dudau@....com,
lorenzo.pieralisi@....com, patrick.bellasi@...bug.net,
orjan.eide@....com, rdunlap@...radead.org, mka@...omium.org
Subject: Re: [PATCH v5 4/5] thermal: devfreq_cooling: Refactor code and switch
to use Energy Model
On 18/03/2020 12:45, Lukasz Luba wrote:
> The overhauled Energy Model (EM) framework support also devfreq devices.
> The unified API interface of the EM can be used in the thermal subsystem to
> not duplicate code. The power table now is taken from EM structure and
> there is no need to maintain calculation for it locally. In case when the
> EM is not provided by the device a simple interface for cooling device is
> used.
>
> There is also an improvement in code related to enabling/disabling OPPs,
> which prevents from race condition with devfreq governors.
>
> [lkp: Reported the build warning]
> Reported-by: kbuild test robot <lkp@...el.com>
> Reviewed-by: Steven Rostedt (VMware) <rostedt@...dmis.org> # for tracing code
> Signed-off-by: Lukasz Luba <lukasz.luba@....com>
The changes are too big, please split this patch into smaller chunks.
> ---
> drivers/thermal/devfreq_cooling.c | 474 ++++++++++++++++--------------
> include/linux/devfreq_cooling.h | 39 +--
> include/trace/events/thermal.h | 19 +-
> 3 files changed, 277 insertions(+), 255 deletions(-)
>
> diff --git a/drivers/thermal/devfreq_cooling.c b/drivers/thermal/devfreq_cooling.c
[ ... ]
> struct devfreq_cooling_device {
> int id;
> struct thermal_cooling_device *cdev;
> struct devfreq *devfreq;
> unsigned long cooling_state;
> - u32 *power_table;
> u32 *freq_table;
> - size_t freq_table_size;
> + size_t max_level;
Could you rename it to 'max_state' ?
[ ... ]
--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs
Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog
Powered by blists - more mailing lists