[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200415204858.2448-6-mathieu.poirier@linaro.org>
Date: Wed, 15 Apr 2020 14:48:56 -0600
From: Mathieu Poirier <mathieu.poirier@...aro.org>
To: bjorn.andersson@...aro.org, ohad@...ery.com
Cc: s-anna@...com, elder@...aro.org, Markus.Elfring@....de,
linux-remoteproc@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [PATCH v2 5/7] remoteproc: Restructure firmware name allocation
Improve the readability of function rproc_alloc_firmware() by using
a non-negated condition.
Suggested-by: Alex Elder <elder@...aro.org>
Signed-off-by: Mathieu Poirier <mathieu.poirier@...aro.org>
---
drivers/remoteproc/remoteproc_core.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c
index ebaff496ef81..0bfa6998705d 100644
--- a/drivers/remoteproc/remoteproc_core.c
+++ b/drivers/remoteproc/remoteproc_core.c
@@ -1984,14 +1984,14 @@ static int rproc_alloc_firmware(struct rproc *rproc,
{
const char *p;
- if (!firmware)
+ if (firmware)
+ p = kstrdup_const(firmware, GFP_KERNEL);
+ else
/*
* If the caller didn't pass in a firmware name then
* construct a default name.
*/
p = kasprintf(GFP_KERNEL, "rproc-%s-fw", name);
- else
- p = kstrdup_const(firmware, GFP_KERNEL);
if (!p)
return -ENOMEM;
--
2.20.1
Powered by blists - more mailing lists