[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAPDyKFpmcXt2oikzz8hKCLecctnZo9PLNZgu-FRnO8y2jfc-kA@mail.gmail.com>
Date: Fri, 17 Apr 2020 13:29:08 +0200
From: Ulf Hansson <ulf.hansson@...aro.org>
To: Jisheng Zhang <Jisheng.Zhang@...aptics.com>
Cc: "linux-mmc@...r.kernel.org" <linux-mmc@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] mmc: sd: use HIGH_SPEED_BUS_SPEED in mmc_sd_switch_hs()
On Fri, 10 Apr 2020 at 08:57, Jisheng Zhang <Jisheng.Zhang@...aptics.com> wrote:
>
> Use the well defined HIGH_SPEED_BUS_SPEED macro in mmc_sd_switch_hs()
> to make code more readable.
>
> Signed-off-by: Jisheng Zhang <Jisheng.Zhang@...aptics.com>
Applied for next, thanks!
Kind regards
Uffe
> ---
> drivers/mmc/core/sd.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
> index 76c7add367d5..43de3190d718 100644
> --- a/drivers/mmc/core/sd.c
> +++ b/drivers/mmc/core/sd.c
> @@ -376,11 +376,11 @@ int mmc_sd_switch_hs(struct mmc_card *card)
> if (!status)
> return -ENOMEM;
>
> - err = mmc_sd_switch(card, 1, 0, 1, status);
> + err = mmc_sd_switch(card, 1, 0, HIGH_SPEED_BUS_SPEED, status);
> if (err)
> goto out;
>
> - if ((status[16] & 0xF) != 1) {
> + if ((status[16] & 0xF) != HIGH_SPEED_BUS_SPEED) {
> pr_warn("%s: Problem switching card into high-speed mode!\n",
> mmc_hostname(card->host));
> err = 0;
> --
> 2.26.0
>
Powered by blists - more mailing lists