[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200417180041.GD199755@google.com>
Date: Fri, 17 Apr 2020 11:00:41 -0700
From: Matthias Kaehlcke <mka@...omium.org>
To: Rajendra Nayak <rnayak@...eaurora.org>
Cc: viresh.kumar@...aro.org, sboyd@...nel.org,
bjorn.andersson@...aro.org, agross@...nel.org,
linux-arm-msm@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Akash Asthana <akashast@...eaurora.org>,
linux-serial@...r.kernel.org
Subject: Re: [PATCH v2 01/17] tty: serial: qcom_geni_serial: Use OPP API to
set clk/perf state
Hi Rajendra,
On Fri, Apr 17, 2020 at 07:34:23PM +0530, Rajendra Nayak wrote:
> geni serial needs to express a perforamnce state requirement on CX
> powerdomain depending on the frequency of the clock rates.
> Use OPP table from DT to register with OPP framework and use
> dev_pm_opp_set_rate() to set the clk/perf state.
>
> Signed-off-by: Rajendra Nayak <rnayak@...eaurora.org>
> Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
> Cc: Akash Asthana <akashast@...eaurora.org>
> Cc: linux-serial@...r.kernel.org
> ---
> drivers/tty/serial/qcom_geni_serial.c | 30 +++++++++++++++++++++++++-----
> include/linux/qcom-geni-se.h | 2 ++
> 2 files changed, 27 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/tty/serial/qcom_geni_serial.c b/drivers/tty/serial/qcom_geni_serial.c
> index 6119090..151012c 100644
> --- a/drivers/tty/serial/qcom_geni_serial.c
> +++ b/drivers/tty/serial/qcom_geni_serial.c
> @@ -9,6 +9,7 @@
> #include <linux/module.h>
> #include <linux/of.h>
> #include <linux/of_device.h>
> +#include <linux/pm_opp.h>
> #include <linux/platform_device.h>
> #include <linux/pm_runtime.h>
> #include <linux/pm_wakeirq.h>
> @@ -128,6 +129,7 @@ struct qcom_geni_serial_port {
> int wakeup_irq;
> bool rx_tx_swap;
> bool cts_rts_swap;
> + bool opp_table;
The name of the variable suggests that it holds a OPP table, something
like 'has_opp_table' would be clearer.
> };
>
> static const struct uart_ops qcom_geni_console_pops;
> @@ -961,7 +963,7 @@ static void qcom_geni_serial_set_termios(struct uart_port *uport,
> goto out_restart_rx;
>
> uport->uartclk = clk_rate;
> - clk_set_rate(port->se.clk, clk_rate);
> + dev_pm_opp_set_rate(uport->dev, clk_rate);
> ser_clk_cfg = SER_CLK_EN;
> ser_clk_cfg |= clk_div << CLK_DIV_SHFT;
>
> @@ -1198,8 +1200,11 @@ static void qcom_geni_serial_pm(struct uart_port *uport,
> if (new_state == UART_PM_STATE_ON && old_state == UART_PM_STATE_OFF)
> geni_se_resources_on(&port->se);
> else if (new_state == UART_PM_STATE_OFF &&
> - old_state == UART_PM_STATE_ON)
> + old_state == UART_PM_STATE_ON) {
> + /* Drop the performance state vote */
> + dev_pm_opp_set_rate(uport->dev, 0);
> geni_se_resources_off(&port->se);
> + }
> }
>
> static const struct uart_ops qcom_geni_console_pops = {
> @@ -1318,13 +1323,20 @@ static int qcom_geni_serial_probe(struct platform_device *pdev)
> if (of_property_read_bool(pdev->dev.of_node, "cts-rts-swap"))
> port->cts_rts_swap = true;
>
> + port->se.opp = dev_pm_opp_set_clkname(&pdev->dev, "se");
> + if (IS_ERR(port->se.opp))
> + return PTR_ERR(port->se.opp);
> + /* OPP table is optional */
> + if (!dev_pm_opp_of_add_table(&pdev->dev))
Even if the OPP table is optional you probably want to fail if the error
is anything other than -ENODEV ("'operating-points' property is not found
or is invalid data in device node.").
> diff --git a/include/linux/qcom-geni-se.h b/include/linux/qcom-geni-se.h
> index dd46494..737e713 100644
> --- a/include/linux/qcom-geni-se.h
> +++ b/include/linux/qcom-geni-se.h
> @@ -24,6 +24,7 @@ enum geni_se_protocol_type {
>
> struct geni_wrapper;
> struct clk;
> +struct opp_table;
>
> /**
> * struct geni_se - GENI Serial Engine
> @@ -39,6 +40,7 @@ struct geni_se {
> struct device *dev;
> struct geni_wrapper *wrapper;
> struct clk *clk;
> + struct opp_table *opp;
This name suggests that the variable holds a single OPP ('struct
dev_pm_opp'). Most other code uses the name 'opp_table', which
also seems a good candidate here.
Powered by blists - more mailing lists