lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 21 Apr 2020 16:53:05 +0200
From:   Vincent Guittot <vincent.guittot@...aro.org>
To:     Chen Yu <yu.c.chen@...el.com>
Cc:     linux-kernel <linux-kernel@...r.kernel.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        Valentin Schneider <valentin.schneider@....com>,
        Ingo Molnar <mingo@...hat.com>,
        Juri Lelli <juri.lelli@...hat.com>,
        Dietmar Eggemann <dietmar.eggemann@....com>,
        Mel Gorman <mgorman@...e.de>, Ben Segall <bsegall@...gle.com>
Subject: Re: [PATCH 2/2][v3] sched: Extract the task putting code from pick_next_task()

On Tue, 21 Apr 2020 at 12:50, Chen Yu <yu.c.chen@...el.com> wrote:
>
> Introduce a new function put_prev_task_balance() to do the balance
> when necessary, and then put previous task back to the run queue.
> This function is extracted from pick_next_task() to prepare for
> future usage by other type of task picking logic.
>
> No functional change.
>
> Suggested-by: Peter Zijlstra <peterz@...radead.org>
> Reviewed-by: Valentin Schneider <valentin.schneider@....com>
> Signed-off-by: Chen Yu <yu.c.chen@...el.com>

Reviewed-by: Vincent Guittot <vincent.guittot@...aro.org>

> ---
> v3: According to Steven's suggestion, fix the comment
>     to change put_next_task() to put_prev_task()
>
>     Rename finish_prev_task() to put_prev_task_balance()
>     as this reflects what we do before picking a new task.
>
>     Per Valentin's suggestion, put the declaration of
>     struct sched_class within the ifdef, given it isn't
>     used outside of it.
> ---
>  kernel/sched/core.c | 39 +++++++++++++++++++++++----------------
>  1 file changed, 23 insertions(+), 16 deletions(-)
>
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 3a61a3b8eaa9..c9d7880f6bf2 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -3904,6 +3904,28 @@ static inline void schedule_debug(struct task_struct *prev, bool preempt)
>         schedstat_inc(this_rq()->sched_count);
>  }
>
> +static void put_prev_task_balance(struct rq *rq, struct task_struct *prev,
> +                                 struct rq_flags *rf)
> +{
> +#ifdef CONFIG_SMP
> +       const struct sched_class *class;
> +       /*
> +        * We must do the balancing pass before put_prev_task(), such
> +        * that when we release the rq->lock the task is in the same
> +        * state as before we took rq->lock.
> +        *
> +        * We can terminate the balance pass as soon as we know there is
> +        * a runnable task of @class priority or higher.
> +        */
> +       for_class_range(class, prev->sched_class, &idle_sched_class) {
> +               if (class->balance(rq, prev, rf))
> +                       break;
> +       }
> +#endif
> +
> +       put_prev_task(rq, prev);
> +}
> +
>  /*
>   * Pick up the highest-prio task:
>   */
> @@ -3937,22 +3959,7 @@ pick_next_task(struct rq *rq, struct task_struct *prev, struct rq_flags *rf)
>         }
>
>  restart:
> -#ifdef CONFIG_SMP
> -       /*
> -        * We must do the balancing pass before put_next_task(), such
> -        * that when we release the rq->lock the task is in the same
> -        * state as before we took rq->lock.
> -        *
> -        * We can terminate the balance pass as soon as we know there is
> -        * a runnable task of @class priority or higher.
> -        */
> -       for_class_range(class, prev->sched_class, &idle_sched_class) {
> -               if (class->balance(rq, prev, rf))
> -                       break;
> -       }
> -#endif
> -
> -       put_prev_task(rq, prev);
> +       put_prev_task_balance(rq, prev, rf);
>
>         for_each_class(class) {
>                 p = class->pick_next_task(rq);
> --
> 2.17.1
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ