[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200422021046.4375-1-bernard@vivo.com>
Date: Tue, 21 Apr 2020 19:10:46 -0700
From: Bernard Zhao <bernard@...o.com>
To: Liviu Dudau <liviu.dudau@....com>,
Brian Starkey <brian.starkey@....com>,
David Airlie <airlied@...ux.ie>,
Daniel Vetter <daniel@...ll.ch>,
dri-devel@...ts.freedesktop.org, linux-kernel@...r.kernel.org
Cc: opensource.kernel@...o.com, Bernard Zhao <bernard@...o.com>
Subject: [PATCH] drm/arm: cleanup coding style in arm a bit
For the code logic, an alarm is thrown after failure, but the
code continues to run and returns successfully, so to the caller
the if check and return branch will never run.
The change is to make the code a bit more readable.
Signed-off-by: Bernard Zhao <bernard@...o.com>
---
drivers/gpu/drm/arm/hdlcd_crtc.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/arm/hdlcd_crtc.c b/drivers/gpu/drm/arm/hdlcd_crtc.c
index af67fefed38d..32bda13250f5 100644
--- a/drivers/gpu/drm/arm/hdlcd_crtc.c
+++ b/drivers/gpu/drm/arm/hdlcd_crtc.c
@@ -160,9 +160,7 @@ static void hdlcd_crtc_mode_set_nofb(struct drm_crtc *crtc)
hdlcd_write(hdlcd, HDLCD_REG_H_SYNC, vm.hsync_len - 1);
hdlcd_write(hdlcd, HDLCD_REG_POLARITIES, polarities);
- err = hdlcd_set_pxl_fmt(crtc);
- if (err)
- return;
+ hdlcd_set_pxl_fmt(crtc);
clk_set_rate(hdlcd->clk, m->crtc_clock * 1000);
}
--
2.26.2
Powered by blists - more mailing lists