[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200425151747.8199-1-oscar.carter@gmx.com>
Date: Sat, 25 Apr 2020 17:17:44 +0200
From: Oscar Carter <oscar.carter@....com>
To: Forest Bond <forest@...ttletooquiet.net>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: Oscar Carter <oscar.carter@....com>,
Malcolm Priestley <tvboxspy@...il.com>,
Quentin Deslandes <quentin.deslandes@...ev.co.uk>,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org,
Joe Perches <joe@...ches.com>
Subject: [PATCH v2 0/3] Refactor the vnt_rf_table_download function
This patch series refactors the vnt_rf_table_download function through
tree patches.
The first one removes the local variable "array" and all the memcpy
function calls because this copy operation from different arrays to this
variable is unnecessary.
The second patch replaces the "goto" statements with a direct "return ret"
as the jump label only returns the ret variable.
The third patch replaces three while loops with three calls to the
vnt_control_out_blocks function. This way avoid repeat a functionality
that already exists.
Changelog v1 -> v2
- Modify the commit changelog of the first patch to clarify the change as
Joe Perches suggested.
Oscar Carter (3):
staging: vt6656: Remove the local variable "array"
staging: vt6656: Use return instead of goto
staging: vt6656: Remove duplicate code in vnt_rf_table_download
drivers/staging/vt6656/rf.c | 85 +++++++------------------------------
1 file changed, 16 insertions(+), 69 deletions(-)
--
2.20.1
Powered by blists - more mailing lists