[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6795eb5d-2208-e83f-77e8-c3aaf15ea50d@intel.com>
Date: Mon, 27 Apr 2020 12:58:37 +0200
From: Cezary Rojewski <cezary.rojewski@...el.com>
To: Brent Lu <brent.lu@...el.com>, alsa-devel@...a-project.org
Cc: Pierre-Louis Bossart <pierre-louis.bossart@...ux.intel.com>,
Liam Girdwood <liam.r.girdwood@...ux.intel.com>,
Jie Yang <yang.jie@...ux.intel.com>,
Mark Brown <broonie@...nel.org>,
Jaroslav Kysela <perex@...ex.cz>,
Takashi Iwai <tiwai@...e.com>, Ben Zhang <benzh@...omium.org>,
Mac Chiang <mac.chiang@...el.com>,
Guennadi Liakhovetski <guennadi.liakhovetski@...ux.intel.com>,
Kuninori Morimoto <kuninori.morimoto.gx@...esas.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] ASoC: bdw-rt5677: channel constraint support
On 2020-04-27 10:37, Brent Lu wrote:
> BDW boards using this machine driver supports only stereo capture and
> playback. Implement a constraint to enforce it.
>
Title for the overall series fits better than the one chosen for actual
patches. "channel constraint support" is misleading. Constraints are
added or removed but certainly not supported.
> Signed-off-by: Brent Lu <brent.lu@...el.com>
> ---
> sound/soc/intel/boards/bdw-rt5677.c | 33 +++++++++++++++++++++++++++++++++
> 1 file changed, 33 insertions(+)
>
> diff --git a/sound/soc/intel/boards/bdw-rt5677.c b/sound/soc/intel/boards/bdw-rt5677.c
> index cc41a34..7963cae 100644
> --- a/sound/soc/intel/boards/bdw-rt5677.c
> +++ b/sound/soc/intel/boards/bdw-rt5677.c
> @@ -22,6 +22,8 @@
>
> #include "../../codecs/rt5677.h"
>
> +#define DUAL_CHANNEL 2
> +
Remove, we need not additional too-obvious macro. One could argue
'STEREO' is a better choice too.
> struct bdw_rt5677_priv {
> struct gpio_desc *gpio_hp_en;
> struct snd_soc_component *component;
> @@ -222,6 +224,36 @@ static int bdw_rt5677_rtd_init(struct snd_soc_pcm_runtime *rtd)
> }
> #endif
>
> +static const unsigned int channels[] = {
> + DUAL_CHANNEL,
Inline as stated above.
> +};
> +
> +static const struct snd_pcm_hw_constraint_list constraints_channels = {
> + .count = ARRAY_SIZE(channels),
> + .list = channels,
> + .mask = 0,
> +};
> +
> +static int bdw_fe_startup(struct snd_pcm_substream *substream)
Entire file uses 'bdw_rt5677_' naming convention. Let's not stray away
from that path now.
> +{
> + struct snd_pcm_runtime *runtime = substream->runtime;
> +
> + /*
> + * On this platform for PCM device we support,
> + * stereo audio
> + */
Sometimes you add a newline add and before, while other times just one,
before the comment. Please streamline the format across all patches in
the series. Comment can be more strict too
/* Board supports stereo configuration only */
> +
> + runtime->hw.channels_max = DUAL_CHANNEL;
Inline. If you really want to avoid using 2, make use of 0-entry of
constrains_channels array.
> + snd_pcm_hw_constraint_list(runtime, 0, SNDRV_PCM_HW_PARAM_CHANNELS,
> + &constraints_channels);
> +
> + return 0;
> +}
> +
> +static const struct snd_soc_ops bdw_rt5677_fe_ops = {
> + .startup = bdw_fe_startup,
> +};
> +
> static int bdw_rt5677_init(struct snd_soc_pcm_runtime *rtd)
> {
> struct bdw_rt5677_priv *bdw_rt5677 =
> @@ -321,6 +353,7 @@ static struct snd_soc_dai_link bdw_rt5677_dais[] = {
> },
> .dpcm_capture = 1,
> .dpcm_playback = 1,
> + .ops = &bdw_rt5677_fe_ops,
> SND_SOC_DAILINK_REG(fe, dummy, platform),
> },
>
>
Powered by blists - more mailing lists