[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200429174120.1497212-1-nivedita@alum.mit.edu>
Date: Wed, 29 Apr 2020 13:41:09 -0400
From: Arvind Sankar <nivedita@...m.mit.edu>
To: Ard Biesheuvel <ardb@...nel.org>
Cc: linux-efi@...r.kernel.org, x86@...nel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 00/10] efi: some cleanups/refactoring for efi/next
This series is on top of efi/next.
Patch 1 fixes the size allocated for x86 boot_params.
Patch 2 refactors the setting of various hi/lo 32-bit fields, mainly on x86.
Patches 3-5 convert the remaining uses of efi_printk to print error
messages to use pr_efi_err instead.
Patches 6-8 refactor initrd loading, moving it into efi-stub-helper.
Patch 9 adds support for x86 builtin command line.
Patch 10 adds error checking for efi_parse_options.
Arvind Sankar (10):
efi/x86: Use correct size for boot_params
efi/libstub: Add a helper function to split 64-bit values
efi/x86: Use pr_efi_err for error messages
efi/gop: Use pr_efi_err for error messages
efi/tpm: Use pr_efi_err for error messages
efi/x86: Move command-line initrd loading to efi_main
efi/libstub: Unify initrd loading across architectures
efi/x86: Drop soft_limit for x86 initrd loading
efi/x86: Support builtin command line
efi/libstub: Check return value of efi_parse_options
.../firmware/efi/libstub/efi-stub-helper.c | 42 +++++-
drivers/firmware/efi/libstub/efi-stub.c | 29 +++--
drivers/firmware/efi/libstub/efistub.h | 32 ++---
drivers/firmware/efi/libstub/file.c | 13 +-
drivers/firmware/efi/libstub/gop.c | 16 +--
drivers/firmware/efi/libstub/tpm.c | 2 +-
drivers/firmware/efi/libstub/x86-stub.c | 121 ++++++++----------
7 files changed, 130 insertions(+), 125 deletions(-)
--
2.26.2
Powered by blists - more mailing lists