lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 1 May 2020 21:15:30 +0900
From:   Joonsoo Kim <>
To:     Christoph Hellwig <>
Cc:     Andrew Morton <>,
        Linux Memory Management List <>,
        LKML <>,
        Vlastimil Babka <>,
        Laura Abbott <>,
        "Aneesh Kumar K . V" <>,
        Mel Gorman <>,
        Michal Hocko <>,
        Johannes Weiner <>,
        Roman Gushchin <>, Minchan Kim <>,
        Rik van Riel <>,
        Christian Koenig <>,
        Huang Rui <>,
        Eric Biederman <>,
        "Rafael J . Wysocki" <>,
        Pavel Machek <>,,
        Joonsoo Kim <>
Subject: Re: [PATCH v2 00/10] change the implementation of the PageHighMem()

2020년 5월 1일 (금) 오후 7:55, Christoph Hellwig <>님이 작성:
> On Fri, May 01, 2020 at 07:52:35PM +0900, Joonsoo Kim wrote:
> > > - New code will pop up which gets it wrong and nobody will notice for
> > >   a long time.
> >
> > Hmm... I think that it's not that hard to decide correct macro. If we rename
> > PageHighMem() with PageDirectMapped(), they, PageDirectMapped() and
> > PageHighMemZone(), are self-explanation macro. There would be no
> > confusion to use.
> What confuses me is why we even need PageHighMemZone - mostly code
> should not care about particular zones.  Maybe just open coding
> PageHighMemZone makes more sense - it is a little more cumersome, but
> at least it makes it explicit what we check for.  I already sent you
> an incremental diff for one obvious place, but maybe we need to look
> through the remaining ones if we can kill them or open code them in an
> obvious way.

I think that PageHighMemZone() is long and complicated enough to have
a macro.

PageHighMemZone(page) = is_highmem_idx(zone_idx(page_zone(page))

Instead of open-code, how about changing the style of macro like as
page_from_highmem()? What PageHighMemZone() represent is derivated
attribute from the page so PageXXX() style may not be appropriate.


Powered by blists - more mailing lists