lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 4 May 2020 10:17:49 +0200
From:   Ard Biesheuvel <ardb@...nel.org>
To:     Arvind Sankar <nivedita@...m.mit.edu>
Cc:     linux-efi <linux-efi@...r.kernel.org>, X86 ML <x86@...nel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v2 00/11] efi: some cleanups/refactoring for efi/next

On Thu, 30 Apr 2020 at 20:28, Arvind Sankar <nivedita@...m.mit.edu> wrote:
>
> This series is on top of efi/next.
>
> Patch 1 fixes the size allocated for x86 boot_params.
> Patch 2 refactors the setting of various hi/lo 32-bit fields, mainly on x86.
> Patch 3 renames pr_efi/pr_efi_err
> Patches 4-6 convert the remaining uses of efi_printk to print error
> messages to use efi_err instead.
> Patch 7 updates dtb= ignored message to efi_err.
> Patches 8-9 refactor initrd loading, moving it into efi-stub-helper.
> Patch 10 adds support for x86 builtin command line.
> Patch 11 adds error checking for efi_parse_options.
>
> Changes from v1:
> - Rename pr_efi/pr_efi_err
> - Drop the soft_limit-removing patch
> - Fix a couple of compile warnings
>
> Arvind Sankar (11):
>   efi/x86: Use correct size for boot_params
>   efi/libstub: Add a helper function to split 64-bit values
>   efi/libstub: Move pr_efi/pr_efi_err into efi namespace
>   efi/x86: Use efi_err for error messages
>   efi/gop: Use efi_err for error messages
>   efi/tpm: Use efi_err for error messages
>   efi/libstub: Upgrade ignored dtb= argument message to error
>   efi/x86: Move command-line initrd loading to efi_main
>   efi/libstub: Unify initrd loading across architectures
>   efi/x86: Support builtin command line
>   efi/libstub: Check return value of efi_parse_options
>

Thanks Arvind, I've queued these up now


>  drivers/firmware/efi/libstub/arm32-stub.c     |  12 +-
>  drivers/firmware/efi/libstub/arm64-stub.c     |  14 +-
>  .../firmware/efi/libstub/efi-stub-helper.c    |  46 ++++++-
>  drivers/firmware/efi/libstub/efi-stub.c       |  63 ++++-----
>  drivers/firmware/efi/libstub/efistub.h        |  32 ++---
>  drivers/firmware/efi/libstub/fdt.c            |  16 +--
>  drivers/firmware/efi/libstub/file.c           |  12 +-
>  drivers/firmware/efi/libstub/gop.c            |  16 +--
>  drivers/firmware/efi/libstub/pci.c            |   8 +-
>  drivers/firmware/efi/libstub/relocate.c       |   2 +-
>  drivers/firmware/efi/libstub/secureboot.c     |   4 +-
>  drivers/firmware/efi/libstub/tpm.c            |   2 +-
>  drivers/firmware/efi/libstub/x86-stub.c       | 122 ++++++++----------
>  13 files changed, 186 insertions(+), 163 deletions(-)
>
> --
> 2.26.2
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ