lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 5 May 2020 20:19:18 +0200
From:   Greg Kroah-Hartman <>
To:     Aishwarya Ramakrishnan <>
Cc:     Dmitry Torokhov <>,
        Andy Shevchenko <>,
        Marco Felsch <>,
        Philipp Zabel <>,
        Mylène Josserand 
Subject: Re: [PATCH] Input: edt-ft5x06: Use DEFINE_DEBUGFS_ATTRIBUTE to
 define debugfs fops

On Tue, May 05, 2020 at 09:03:24PM +0530, Aishwarya Ramakrishnan wrote:
> It is more clear to use DEFINE_DEBUGFS_ATTRIBUTE to define debugfs file
> operation rather than DEFINE_SIMPLE_ATTRIBUTE.

No it is not, why do you think so?

The two defines do different things, that is why we have 2 different
defines.  You can not just replace one with the other without
understanding why one was used and not the other one.

Did you test this change to verify that everything still works
properly?  Why is it needed to be changed at all?


greg k-h

Powered by blists - more mailing lists