lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 12 May 2020 15:14:46 +0800
From:   "Huang\, Ying" <ying.huang@...el.com>
To:     Michal Hocko <mhocko@...nel.org>
Cc:     Andrew Morton <akpm@...ux-foundation.org>, <linux-mm@...ck.org>,
        <linux-kernel@...r.kernel.org>, Minchan Kim <minchan@...nel.org>,
        Tim Chen <tim.c.chen@...ux.intel.com>,
        Hugh Dickins <hughd@...gle.com>
Subject: Re: [PATCH] mm, swap: Use prandom_u32_max()

Michal Hocko <mhocko@...nel.org> writes:

> On Tue 12-05-20 14:41:46, Huang Ying wrote:
>> To improve the code readability and get random number with higher
>> quality.
>
> I understand the readability argument but why should prandom_u32_max
> (which I was not aware of) provide a higher quality randomness?

I am not expert on random number generator.  I have heard about that the
randomness of the low order bits of some random number generator isn't
good enough.  Anyway, by using the common implementation, the real
random number generator expert can fix the possible issue once for all
users.

>> Signed-off-by: "Huang, Ying" <ying.huang@...el.com>
>> Cc: Michal Hocko <mhocko@...e.com>
>> Cc: Minchan Kim <minchan@...nel.org>
>> Cc: Tim Chen <tim.c.chen@...ux.intel.com>
>> Cc: Hugh Dickins <hughd@...gle.com>
>
> To the change itself
> Acked-by: Michal Hocko <mhocko@...e.com>

Thanks!

Best Regards,
Huang, Ying

>> ---
>>  mm/swapfile.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>> 
>> diff --git a/mm/swapfile.c b/mm/swapfile.c
>> index a0a123e59ce6..2ec8b21201d6 100644
>> --- a/mm/swapfile.c
>> +++ b/mm/swapfile.c
>> @@ -3220,7 +3220,7 @@ SYSCALL_DEFINE2(swapon, const char __user *, specialfile, int, swap_flags)
>>  		 * select a random position to start with to help wear leveling
>>  		 * SSD
>>  		 */
>> -		p->cluster_next = 1 + (prandom_u32() % p->highest_bit);
>> +		p->cluster_next = 1 + prandom_u32_max(p->highest_bit);
>>  		nr_cluster = DIV_ROUND_UP(maxpages, SWAPFILE_CLUSTER);
>>  
>>  		cluster_info = kvcalloc(nr_cluster, sizeof(*cluster_info),
>> -- 
>> 2.26.2

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ